Previous Thread
Next Thread
Print Thread
Rate Thread
#129933 12/15/2001 2:35 PM
Joined: Jun 2000
Posts: 536
J
josh Offline OP
Member
OP Offline
Member
J
Joined: Jun 2000
Posts: 536
I get this error when I try to close a topic:
quote:
An error has occured:


Can't obtain exclusive lock: Bad file descriptor at /home/coders-n/public_html/ultanime/cgi-bin/ubb_lib_files.cgi line 572.


Please inform the board administration of this error so that they may fix the problem. Thank you!



Here are lines above and after line 572:
quote:
sub sh_lock {
flock(FILE, LOCK_SH) or die "Can't obtain shared lock: $!";
} #end shared lock sr

sub lock {
flock(FILE, LOCK_EX) or die "Can't obtain exclusive lock: $! ";
} #end lock sr

sub unlock {
flock(FILE, LOCK_UN) or die "Can't release lock: $!";
} # end unlock sr



//i wanna scream, show the world i have an inside.
i wanna bleed, let the blood flow, that keeps me alive.
Sponsored Links
#129934 12/15/2001 2:39 PM
Joined: Jun 2001
Posts: 729
1
Coder
Offline
Coder
1
Joined: Jun 2001
Posts: 729
Make sure your files are uploaded int he prope forumat. All fiels have proper permissions (*.cgi = 755 : vars*.cgi = 777) Then if you still have the error revert back to your old copies (you did make backup right?) and try re-hacking.

I find I make simple little mistakes like these when I am working on the system...

#129935 12/15/2001 3:04 PM
Joined: Jun 2000
Posts: 536
J
josh Offline OP
Member
OP Offline
Member
J
Joined: Jun 2000
Posts: 536
quote:
Originally posted by 1QuickSI:
Make sure your files are uploaded int he prope forumat. All fiels have proper permissions (*.cgi = 755 : vars*.cgi = 777) Then if you still have the error revert back to your old copies (you did make backup right?) and try re-hacking.

I find I make simple little mistakes like these when I am working on the system...


Yeah I CHMODed all fine, and uploaded all fine, but as for the backup, I'm not sure, well I mean I have a backup, but I was doing lots of hacks last night so I'm not sure which backup it's from and I don't wanna do alot of hacks over if I did this hack before a whole bunch. Also I can close the topic by clicking the close topic link when I reply, just can't from manually clicking the button. So if anyone could help me I'd be greatly appreciated. BTW I'm running 6.1.0.3, my forum url is http://www.ultanime.net/cgi-bin/ultimatebb.cgi & all of the hacks I have installed so far are:
AIM ICQ YHOO
Anchor
Avatar
Content Enforcer
Custom Status
Hyper Cells
Last Post Profile
Last Reply By
Memberlist
Mod Log
Mod Wordlets
MyStyle
Name Effects
Nick Ban
No Count To Forum
PM System
Smile Mod
Welcome PM
Who's Online
Who's Online Addon
UBB Code Buttons
Sticky Topics

You can also contact me on AIM @ ptnmew.

Thanks!


//i wanna scream, show the world i have an inside.
i wanna bleed, let the blood flow, that keeps me alive.
#129936 12/16/2001 1:09 AM
Joined: Jun 2000
Posts: 536
J
josh Offline OP
Member
OP Offline
Member
J
Joined: Jun 2000
Posts: 536
^bump^


//i wanna scream, show the world i have an inside.
i wanna bleed, let the blood flow, that keeps me alive.
#129937 12/16/2001 12:58 PM
Joined: Jun 2000
Posts: 536
J
josh Offline OP
Member
OP Offline
Member
J
Joined: Jun 2000
Posts: 536
^bump^

Sorry to bump again but I really need help to get this fixed ;_;.


//i wanna scream, show the world i have an inside.
i wanna bleed, let the blood flow, that keeps me alive.
Sponsored Links
#129938 12/17/2001 7:58 AM
Joined: Jun 2001
Posts: 23
T
Junior Member
Offline
Junior Member
T
Joined: Jun 2001
Posts: 23
hello mate i had the same problem and then upgraded to 6.1.0.3 and that sorted it

#129939 12/17/2001 10:06 AM
Joined: Jun 2000
Posts: 536
J
josh Offline OP
Member
OP Offline
Member
J
Joined: Jun 2000
Posts: 536
i am on 6.1.0.3


//i wanna scream, show the world i have an inside.
i wanna bleed, let the blood flow, that keeps me alive.
#129940 12/17/2001 3:21 PM
Joined: Jun 2001
Posts: 23
T
Junior Member
Offline
Junior Member
T
Joined: Jun 2001
Posts: 23
take out the modlog hack then that should sort it as i just installed it and got the error again removed it and now works fine

#129941 12/17/2001 7:28 PM
Joined: Jun 2000
Posts: 536
J
josh Offline OP
Member
OP Offline
Member
J
Joined: Jun 2000
Posts: 536
quote:
Originally posted by tazman:
take out the modlog hack then that should sort it as i just installed it and got the error again removed it and now works fine

Ok thanks, I'll go and remove that hack now and report back here when i'm done hopefully that it'll work .


//i wanna scream, show the world i have an inside.
i wanna bleed, let the blood flow, that keeps me alive.
#129942 12/17/2001 7:39 PM
Joined: Jun 2000
Posts: 536
J
josh Offline OP
Member
OP Offline
Member
J
Joined: Jun 2000
Posts: 536
Thank you so much, I took out that hack and now everything works great.

Thank you so much man ^_____^!!!


//i wanna scream, show the world i have an inside.
i wanna bleed, let the blood flow, that keeps me alive.
Sponsored Links
#129943 12/18/2001 3:59 AM
Joined: Jun 2001
Posts: 23
T
Junior Member
Offline
Junior Member
T
Joined: Jun 2001
Posts: 23
no problem mate anytime


Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
jgeoff
jgeoff
NJ
Posts: 96
Joined: April 2001
Forum Statistics
Forums63
Topics37,557
Posts293,856
Members13,847
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,819
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 70
Gizmo 16
Brett 7
WebGuy 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2021 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Snapshot build 20210915)
Responsive Width:

PHP: 7.3.29 Page Time: 0.017s Queries: 36 (0.009s) Memory: 0.8358 MB (Peak: 0.8984 MB) Data Comp: Zlib Server Time: 2021-10-27 10:37:01 UTC
Valid HTML 5 and Valid CSS