Previous Thread
Next Thread
Print Thread
Rate Thread
Page 4 of 6 1 2 3 4 5 6
#131313 03/16/2001 12:25 PM
Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
CopyCat, that's SWEET! Can I modify that for the official release package? Full credits to you of course - I'll have to modify it so it's Control Panel compatible, etc. but I'll like to use your code as a base!

TIA!

Sponsored Links
#131314 03/16/2001 12:57 PM
Joined: Dec 2000
Posts: 595
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 595
sure, go ahead smile

Joined: Mar 2001
Posts: 117
Q
Member
Offline
Member
Q
Joined: Mar 2001
Posts: 117
can u add in this feature?

"Allow users to upload their own avatars and only they can use their own avatars"

There was such hacking for UBB 5 in http://www.vietson.com

Please.

Joined: Oct 2000
Posts: 2,667
C
Veteran
Offline
Veteran
C
Joined: Oct 2000
Posts: 2,667
OK qasic I've found a documentation problem !!

if the Picture Field option in the control panel is set to : Do not even display this field as an option.

the avatars will NOT SHOW in registration or profil page even if they are activated in the avatar control panel !

maybe you should delete this option completly from CP since you deleted it from the templates

This is probably the problem Yoruku was faced with

also in cp_common.pl there is 2 lines
document.writeln("");

You should explain which one to use since one is for admins and the other one is for mods

next smile
for the upload section of the CP you should add a browse button

See Ya laugh


Do you believe in love at first sight,
or should I walk by again?
Joined: Oct 2000
Posts: 2,667
C
Veteran
Offline
Veteran
C
Joined: Oct 2000
Posts: 2,667
also for the custom avatars, what happens if the user changes his public name, won't he also loose his avatar ? Shouldn't we use user numbers for custom avatars ?

just my 2 cents laugh

also an other doc error, you ask people to make a dir named 'avatar' then in the paths of the config files the dir is 'avatars' not much but it might get people confused and they might not understand why it doesn't work. wink


Do you believe in love at first sight,
or should I walk by again?
Sponsored Links
#131318 03/17/2001 11:36 AM
Joined: Oct 2000
Posts: 2,667
C
Veteran
Offline
Veteran
C
Joined: Oct 2000
Posts: 2,667
*BUG*

under netscape, when you go to your profile, the layout is messed up !!

you can't modifie the 3 next options after avatar and the avatar table is way too high !! (table height is 3 - 4 times what i'ts supposed to be)

there might be a missing tag somewhere in the code


Do you believe in love at first sight,
or should I walk by again?
Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Noted. Trying to fix it but it's proving to be extremely difficult frown

Joined: Feb 2001
Posts: 35
M
Member
Offline
Member
M
Joined: Feb 2001
Posts: 35
I've still got the Netscape bug, but I just installed this bad boy on ubb6 gold and it's probably the most professional hack i've seen.

kudos to qasic smile


Fear is the mind-killer. Fear is the little death that brings total obliteration. I will face my fear. I will permit it to pass over me and through me. And when it has gone past me I will turn to see fear's path. Where the fear has gone there will be nothing. Only I will remain.
Joined: Dec 2000
Posts: 595
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 595
qasic,

my other utility for the v5 avatar hack, the upload custom avatar, should be working fine with v6 too. its just a matter of changing the require ubb config file and a couple of ubb config variables used through the code. the hack can be found here

http://banco.jogosonline.com.br/avatars/uploadavatar.zip

the thread with info on the hack is here

https://www.ubbdev.com/ubbcgi/ultimatebb.cgi?ubb=get_topic&f=7&t=000360

i would suggest you to use usernumbers for the custom avatar files, because weird user names can mess image file names, making some impossible to download. you can drop me an e-mail if you have any question about the code, as i think its very simple to understand (and its all commented through the routines). maybe the image file size module, that can be found at cpan.org, can be uploaded to the ubbs module folder for use with the code, but i didnt research to see if that can really be done. good luck [Linked Image] .

[ March 17, 2001: Message edited by: CopyCat ]

Joined: Feb 2001
Posts: 90
S
Member
Offline
Member
S
Joined: Feb 2001
Posts: 90
qasic, have you released the hack that works with UBB6 Gold and has Copy Cats mods in it?

Sponsored Links
Joined: Mar 2001
Posts: 24
B
Junior Member
Offline
Junior Member
B
Joined: Mar 2001
Posts: 24
Hi CopyCat,
How do I install Image::Size to server?
What do I have to modify pl files?

Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
CopyCat,

Thank you for your custom avatar upload module. However, I will not be using it because at this time, I'll only be allowing admins to upload custom avatars.

Custom avatars at this time use login names but this will probably need to changed for the reason CopyCat mentioned.

Finally, I've created a work-around solution for the Netscape problem but unfortunately, I'm unable to provide a "good" solution to the problem frown If anyone who is good at HTML could help out, that'll be greatly appreciated!

qasic

Joined: Feb 2001
Posts: 90
S
Member
Offline
Member
S
Joined: Feb 2001
Posts: 90
What do you need qasic? I have been working with HTML for the longest of times, and know how finicky Nutscrape can be. What is the problem?

Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Basically the layers are causing Netscape to stop input of all form elements coming after the layers. I've tried everything from changing the layer's sizes to width to putting them in tables without any real effect frown

#131327 03/18/2001 10:34 AM
Joined: Oct 2000
Posts: 5
M
Junior Member
Offline
Junior Member
M
Joined: Oct 2000
Posts: 5
here's a suggestion for the view all avatars,

give the admins the option of splitting the avatar page into many pages. If the admin checks no, the the option does not appear in the edit profile/registration pages.

For this reason, if someone has 100+ avatars, it'll take forever to load

My site once had almost 800 avatars and it took my staff member with DSL 11 min to load.

My 2 cents


mako
#131328 03/18/2001 11:34 AM
Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
This option has already been incoporated into v0.0004 wink

qasic

#131329 03/18/2001 11:55 AM
Joined: Feb 2001
Posts: 35
M
Member
Offline
Member
M
Joined: Feb 2001
Posts: 35
I don't really know the problem mako is having. i have 500+ avatars and the page takes no more then 30seconds to load, and i'm using a 56k ?


Fear is the mind-killer. Fear is the little death that brings total obliteration. I will face my fear. I will permit it to pass over me and through me. And when it has gone past me I will turn to see fear's path. Where the fear has gone there will be nothing. Only I will remain.
Joined: Feb 2001
Posts: 90
S
Member
Offline
Member
S
Joined: Feb 2001
Posts: 90
qasic, you might want to use the
code to offset the layer lower than what it should be, as was the bug reported by some other earlier poster.

Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Are you able to try v0.0003 (or the upcoming v0.0004) and figure a solution using Netscape? TIA!

Joined: Dec 2000
Posts: 9
D
Member
Offline
Member
D
Joined: Dec 2000
Posts: 9
I experienced this problem with NS myself. What I have seen is that you can't use layers along with forms. The layering gets all whacked. I have to find a workaround for what you are describing myself.

The only workaround I can see is removing the layers and going straight to using tables only. That's the only way I have seen nutscrape ever work.

Also, if you use embedded styles (ie you will find yet another NS bug. NS cannot render embedded tags at all. You may have to approach it by changing the code to include Javascript that checks the browser and implements a different style altogether.

An example:
Code
code:

I suck at JS myself but I am sure you can all get the purpose of the code.

Did that help or was it just worthless rambling to all of you?

[ March 18, 2001: Message edited by: DisMan ]

Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Disman,

I defintely understand what you're saying and that's the exact problem I'm experiencing. However, I'm afraid I can't separate it into tables because that'll ruin the structure of the current implentation. Currently, by hack TURNS OFF the image prevew if you're using the Netscape browser but I'll like to find a better solution than this.

I know the style of hack worked for UBB 5; I just can't get it working of UBB 6 frown MasterMind, do you have any ideas? You coded the UBB 5 version; perhaps you can help.

qasic

Joined: Mar 2001
Posts: 29
S
Junior Member
Offline
Junior Member
S
Joined: Mar 2001
Posts: 29
Is this hack still beta or is it finished? Will you move it to the finished section once it is? I'm new to this forum so don't know how it works.

The only reason I'm not installing this one is because i don't want to manually edit the file... I want it like my old hack where I just added new avatars to a directory and that was that!

Thanks, this forum rocks!

#131335 03/18/2001 10:06 PM
Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
LOL Sinatra!

You can do that as well! Once it's initially set up, you don't have to touch it if you don't want to!

And now, Qasic Productions, Inc. Proudly Announces:

Name: Avatar Hack
Version: 0.0004 (upgrade instructions included)
New Features/Bug Fixes:

  • Moderators may now manage Avatars (upload/rename/delete)
  • Avatar List (lots of coding courtesy of CopyCat)
  • Now uses Member Numbers for Custom Avatars (conversion script included)
  • Previous Saved Avatar now automatically loads
  • Bug fix on wording (template)
  • Netscape workaround incorporated


Link: http://www.qasic.com/ubbhacks.html

This is probably the final version for this hack. Further upgrades will probably be for bug fixes and such (espicially the Netscape bug).

This hack has been a great accomplishment for me. It was the first hack to totally have an independent control panel module and be wordletized based as well!

Well, what are you waiting for? Download it and hack it into your UBB!

Users who are usin mod_perl &/or PerlEx please report any errors here immediately.

qasic

[ March 18, 2001: Message edited by: qasic ]

#131336 03/18/2001 10:17 PM
Joined: Mar 2001
Posts: 29
S
Junior Member
Offline
Junior Member
S
Joined: Mar 2001
Posts: 29
qasic: you are the man!

yahooooooooooooo! laugh

#131337 03/19/2001 12:06 AM
Joined: Oct 2000
Posts: 5
M
Junior Member
Offline
Junior Member
M
Joined: Oct 2000
Posts: 5
you got my vote qasic,
cool


mako
Joined: Mar 2001
Posts: 29
S
Junior Member
Offline
Junior Member
S
Joined: Mar 2001
Posts: 29
OK, let me say that this is the best damn thing for my UBB, I love you to death you great SOB!!!!!

thanks a lot... tipsy

Joined: Sep 2000
Posts: 77
D
Member
Offline
Member
D
Joined: Sep 2000
Posts: 77
wohooo it works perfect I love it laugh

Joined: May 2000
Posts: 26
C
Member
Offline
Member
C
Joined: May 2000
Posts: 26
good work qasic, but.. you said you were going to add me into the :
CONTRIBUTORS:
catagories, but you never did
but good work

Joined: Mar 2001
Posts: 29
S
Junior Member
Offline
Junior Member
S
Joined: Mar 2001
Posts: 29
I can't get the custom avatar to work.

I name the custom image after my MEMBER NUMBER (00000001.jpg) and upload to my avatar/custom (chmod 777 - checked) dir but when I do a test post nithing is displayed in under my name as if there were no avatar. So I go in my profile and select any avatar and post another message. Well, then I get the avatar I just selected. Help meh ol' buddy... any suggestions?

BTW - I see the custom image in Avatar Management and everything is working fine with regards to rename/upload/delete.

confused

Joined: May 2000
Posts: 26
C
Member
Offline
Member
C
Joined: May 2000
Posts: 26
uhmm, you have to name the avatar to the users_name.gif
then it should work

Joined: Mar 2001
Posts: 29
S
Junior Member
Offline
Junior Member
S
Joined: Mar 2001
Posts: 29
The instructions say the member's number, but anyway, I tried it as the member's name and it still doesn't work.

My test account is "MikeDee," so I named a .gif as MikeDee.gif and uploaded to custom dir. It didn't work.

Joined: Oct 2000
Posts: 2,667
C
Veteran
Offline
Veteran
C
Joined: Oct 2000
Posts: 2,667
you HAVE to use member number
if your number is 00000018 then your image has to be named 18.gif or 18.jpg


Do you believe in love at first sight,
or should I walk by again?
Joined: Oct 2000
Posts: 2,667
C
Veteran
Offline
Veteran
C
Joined: Oct 2000
Posts: 2,667
qasic, here are a few things to add ...

a wordlet for 'close window' in avatar list
a wordlet for 'custom'

also the custom tag should be underneath the 'none' tag otherwise it is not viewable and people may not think of going up !


Do you believe in love at first sight,
or should I walk by again?
Joined: Mar 2001
Posts: 29
S
Junior Member
Offline
Junior Member
S
Joined: Mar 2001
Posts: 29
THANKS - IT WORKS... I was adding the 0's

yeah, the CUSTOM needs to be under the NONE in the select input cause a lot of people won't see it... great job!

Joined: Mar 2001
Posts: 117
Q
Member
Offline
Member
Q
Joined: Mar 2001
Posts: 117
still have a problem
whenever I upload a new pic to the custom directory (e.g. 18.jpg)

member no. 18 cannot choose cUSTOM in the box.
and if I modify the picture link in the cp myself, they can use the pic, however, whenever they update the profile, the pic will turn to 2.jpg (which is the earliest pic)

Joined: Oct 2000
Posts: 2,667
C
Veteran
Offline
Veteran
C
Joined: Oct 2000
Posts: 2,667
q ware I don't understand your problem !!
All I can say rigt now is your custom fir chmoded correctly ?

otherwise please re-explain


Do you believe in love at first sight,
or should I walk by again?
Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
q_ware, give us a URL and we'll check it out.

Chuck, I don't understand. What did you contribute? I've lost track of time ...

I'll add those wordlets into v0.0005 when I get the chance.

Furthermore, files named xxxxxxxx.gif or xxxxxxxx.jpg SHOULD work. My bet is that the custom Avatar is ABOVE the none but I'll double check this on my test system.

qasic

Joined: Oct 2000
Posts: 2,667
C
Veteran
Offline
Veteran
C
Joined: Oct 2000
Posts: 2,667
Quote
quote:
I don't understand your question


Do you believe in love at first sight,
or should I walk by again?
Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Chuck, I'm referring to the following quote:

Quote
quote:
Yes, the Custom above the None would be prefereable now - I'll defintely code this in for v0.0005.

Yes XXXXXXXX.gif or XXXXXXXX.jpg custom avatars should work (1.jpg or 00000001.jpg) should both work. If this is a bug, I'll need to fix it ASAP.

qasic

Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Oh found the bug for the script. Script wasn't detecting 00000002.jpg as custom avatars but was for 00000002.gif. To fix it:

Open up avatar_list.pl

Goto Line 157 and change it to:

Quote
quote:
That should fix the problems. This fix will be incorporated in v0.0005.

qasic

Page 4 of 6 1 2 3 4 5 6

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Bill B
Bill B
Issaquah, WA
Posts: 87
Joined: December 2001
Forum Statistics
Forums63
Topics37,558
Posts293,857
Members13,848
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,819
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 70
Gizmo 16
Brett 7
WebGuy 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2022 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Snapshot build 20220120)
Responsive Width:

PHP: 7.3.29 Page Time: 0.036s Queries: 95 (0.013s) Memory: 0.9978 MB (Peak: 1.1900 MB) Data Comp: Zlib Server Time: 2022-01-27 04:59:18 UTC
Valid HTML 5 and Valid CSS