Previous Thread
Next Thread
Print Thread
Rate Thread
Page 3 of 5 1 2 3 4 5
Joined: Apr 2001
Posts: 3
R
Junior Member
Offline
Junior Member
R
Joined: Apr 2001
Posts: 3
I just wanted to asy that I have the same problem with the multipages ...

I'm using UBB v6.01

- Roodah

Sponsored Links
Joined: Aug 2000
Posts: 226
A
Member
Offline
Member
A
Joined: Aug 2000
Posts: 226
It's working fine for me as well. I am on 6.02

Amy

Joined: Jan 2000
Posts: 313
S
Member
Offline
Member
S
Joined: Jan 2000
Posts: 313
Guys DOUBLECHECK you are using the code from Allen's first post in this thread, it DOES work!

Joined: Sep 2000
Posts: 68
H
Member
Offline
Member
H
Joined: Sep 2000
Posts: 68
hm, Slurpee ... strange. I've installed it, i think, 5 times, and yes i took the file from Allens first post. It doesn't work for many people.

Joined: Apr 2001
Posts: 3
R
Junior Member
Offline
Junior Member
R
Joined: Apr 2001
Posts: 3
Ok guys, now we know why it doesn't show the correct pages: The script doesn't hop into this query:

if ($total_pages > 1) {
$page_num = "&p=$total_pages";
}


Don't ask me why! The funny thing is, $total_pages equals sometimes more than 1, but the loop gets not executed. I checked it out with a simple print "$total_pagesn"; - it does not show any values. When I set the print-command above the if-block, it prints out the correct number of pages. It seems that anything isn't ok with the if-block. But what? I don't see any wrong things in it ...

- Roodah

[ April 03, 2001: Message edited by: Roodah ]

Sponsored Links
Joined: Apr 2001
Posts: 3
R
Junior Member
Offline
Junior Member
R
Joined: Apr 2001
Posts: 3
Ok, I think I have it. In Allen's version, the if-block I writed I my last posting is out of the if ($total_posts > $vars_display{HTMLDisplayMax}) { ... }. And that's the cause of our problems. $total_pages is defined with a my-definition, so out of the if ($total_posts > $vars_display{HTMLDisplayMax}) { ... }-thing $total_pages = 0! There are 2 ways to fix the problem: 1st Delete the my out of the my $total_pages = int ($total_posts / $vars_display{HTMLDisplayMax}); or 2nd set the if ($total_pages > 1) { ... }-block into the if ($total_posts > $vars_display{HTMLDisplayMax}) { ... }-thing.

I used the 2nd way, so my code in ubb_forum.cgi is:

Code
code:

- Roodah

[ April 03, 2001: Message edited by: Roodah ]

[ April 03, 2001: Message edited by: Roodah ]

Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Can anyone else verify this?

q

Joined: Aug 2000
Posts: 226
A
Member
Offline
Member
A
Joined: Aug 2000
Posts: 226
it's better than that. You don't need this line at all:

Code
code:

because, if the number of posts is greater than the max allowed per page, there is GOING to be more than one page.

I removed it a while back and moved the page number code into the main if block. It's been working like a charm.

Amy

Joined: Mar 2001
Posts: 24
D
Junior Member
Offline
Junior Member
D
Joined: Mar 2001
Posts: 24
Ok, that exactly must i change, so it will work correct. confused

Joined: Dec 2000
Posts: 34
R
Member
Offline
Member
R
Joined: Dec 2000
Posts: 34
Thanks, amy! Can you post exactly what the new snippet of code looks like so we don't err on making the changes?

Sponsored Links
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
please... added back here does show the error... frown


- Allen wavey
- What Drives You?
Joined: Dec 2000
Posts: 34
R
Member
Offline
Member
R
Joined: Dec 2000
Posts: 34
I commented out all three lines, amy, (the if statement and opening and closing braces) and the behaviour does not change.

Any other ideas? Perhaps a fix to the source code, so that I can re-download it? Or even better a quick "how to upgrade" doc.

smile

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
ahhh, I used roodah's change and it fixed it here... I'll document it and post here this evening when I have it uploaded again.

For those with it already installed, change this section in ubb_forum.cgi to this:
Code
code:


- Allen wavey
- What Drives You?
Joined: Jan 2000
Posts: 313
S
Member
Offline
Member
S
Joined: Jan 2000
Posts: 313
Yeah Allen, thanks for making me look bad. tipsy

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
OK, file linked to on front page has been updated, plus it is now using the vars_wordlets_mods.cgi most of you already have, if you don't, then check DPK's Mod for it, as we are working towards standardizing the wordlets files for modifications added.

Slurpee: tipsy


- Allen wavey
- What Drives You?
Joined: Feb 2001
Posts: 74
S
Member
Offline
Member
S
Joined: Feb 2001
Posts: 74
Hi, I just updated my UBB to 6.02 and went back and installed sevral of the hacks I collected including yours. I've ran into a problem; in private forums, when you click Show Topics from last 45 days, or higher, it brings up
Quote
quote:
This may not have been due to your hack, I currently have 6 hacks installed:
Anchor, last reply, News Fader, Custom Rank, and MODs Wordlets.cgi
Any Suggestions?


{SFP} Sonic
Expecting the Unexpected!
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Hey Paul, not sure where your problem may be, but it isn't affecting us here (I just checked) - right now, we only have who's online and this one installed.


- Allen wavey
- What Drives You?
Joined: Jan 2000
Posts: 313
S
Member
Offline
Member
S
Joined: Jan 2000
Posts: 313
Nope just checked my forum, no private forum problem like that.

Joined: Feb 2001
Posts: 74
S
Member
Offline
Member
S
Joined: Feb 2001
Posts: 74
Could this be a CHMOD problem? I've tried reinstalling the hacks using a fresh upgrade zip.

I guess I'll just reinstall the whole board then try each hack one at a time.

[ April 03, 2001: Message edited by: Paul D ]


{SFP} Sonic
Expecting the Unexpected!
Joined: Dec 2000
Posts: 34
R
Member
Offline
Member
R
Joined: Dec 2000
Posts: 34
Thank you Allen, that did the trick. Whew. cool cool cool

Joined: Feb 2001
Posts: 5
D
Junior Member
Offline
Junior Member
D
Joined: Feb 2001
Posts: 5
I can't get the "Latest Reply by" to display. It just displays : username

Here is a var_wordlets_mods.cgi file:
%vars_wordlets_mods = (
last_reply_by => "Last reply by",
statistic_header => "Statistic",
statistic_monthly_hits => "Monthly Hits:",
statistic_total_posts => "Total Posts:",
statistic_total_topics => "Total Topics:",
statistic_total_forums => "Total Forums:",
statistic_total_members => "Total Members:",
statistic_average_member_posts => "Average Posts of each Member:",
statistic_average_posts => "Average Posts Per Forum:",
statistic_average_topic => "Average Topics Per Forum:",
statistic_newest_member => "Last member to register is",
statistic_featured_member => "Featured member is",
);
1;

All the statistic stuff works!

UBB 6.02+statistics+latestreply+hypercells+viewcounter107e

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
hmmm.. can you set the wordlets in the cp? And do you have a link to the problem? What version are you running? need the info... you are the first to report this...


- Allen wavey
- What Drives You?
Joined: Dec 2000
Posts: 3
J
Junior Member
Offline
Junior Member
J
Joined: Dec 2000
Posts: 3
OK, I figured out my own problem...Since I wasn't using the file vars_wordlets_mods.cgi before, I had to add this statement to ultimatebb.cgi

require "$vars_config{VariablesPath}/vars_wordlets_mods.cgi";

I'm no programmer, but I don't understand why the statistic hack was working....

Joined: Sep 2000
Posts: 49
K
Member
Offline
Member
K
Joined: Sep 2000
Posts: 49
Any one try this in 6.03 yet? geez.. I just upgraded to 6.02 the other day too..lol.. can't win sometimes. laugh

Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
6.03 is fine for me on a board I hacked it on.

q

Joined: Feb 2001
Posts: 61
S
Member
Offline
Member
S
Joined: Feb 2001
Posts: 61
working with 6.03 here too smile

Joined: Mar 2000
Posts: 57
N
NSA Offline
Member
Offline
Member
N
Joined: Mar 2000
Posts: 57
Quote
quote:
Argh. I've read through the previous posts and tried what a few suggested but to no avail. Any help?

Thanks! And I used the link from Allen's posts up front.

[Edit: 6.03 almost-fresh install]

[ April 10, 2001: Message edited by: NSA ]

Joined: Mar 2001
Posts: 9
S
Junior Member
Offline
Junior Member
S
Joined: Mar 2001
Posts: 9
It works for me... laugh

Joined: Mar 2000
Posts: 57
N
NSA Offline
Member
Offline
Member
N
Joined: Mar 2000
Posts: 57
Ahah I fixed it. Found the problem.

Okay in the CP, under General Display Settings, and under the "Max # of Posts displayed per page" there are all the settings and the bottom setting is "Posts Maximum Per Page". Thats what I chose, because I did not want multiple pages on my Bored.. however, I suppose this is a Bug? An error? Because I dont think it works the same as the "no maximum per page" that existed on 5.xx. Now I'm pretty dumb, but I changed it and that fixed my problem.

Any ideas? Three cheers to being bored and futzing around with options laugh

[ April 10, 2001: Message edited by: NSA ]

Joined: Feb 2001
Posts: 67
C
Member
Offline
Member
C
Joined: Feb 2001
Posts: 67
Quote
quote:
Thanks. yes for people upgrading you should ut this into the install file too.
after adding this i was able to see last reply by. Thx jdearing


What Would UBB look like with out hacks?
Joined: Feb 2001
Posts: 497
M
Enthusiast
Offline
Enthusiast
M
Joined: Feb 2001
Posts: 497
??????????????????????
how can i do:


after reply [and edit] go to the last post, and not to the first.


[add in ubb_lib_posting.cgi near line 830 ?]
????????????????????????

Joined: Feb 2001
Posts: 67
C
Member
Offline
Member
C
Joined: Feb 2001
Posts: 67
Quote
quote:

I think their was a mod about this. but it never got finished. i supose.


What Would UBB look like with out hacks?
Joined: Mar 2001
Posts: 29
M
Junior Member
Offline
Junior Member
M
Joined: Mar 2001
Posts: 29
Just so everyone knows, this hack works perfectly on 6.04.

Joined: Sep 2000
Posts: 49
K
Member
Offline
Member
K
Joined: Sep 2000
Posts: 49
I agree.. tested ok on my 6.04 board. laugh

Joined: Dec 2000
Posts: 595
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 595
i got this error

No member profile found for member number:

and no member number. i got some 0 bytes member files a couple of days ago, low on server space.

Joined: Dec 2000
Posts: 595
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 595
solved the problem. i changed the last post routine in ubb_forums.cgi to this

# begin last post hack
if ($last_post[1] eq "000000"){
$last_post_username = "";
}
else { $last_post_num = &GetUserNumber($last_post[2]);
if ($last_post_num ne '') {
# get latest public name for latest post replier!
my @user_profile = '';
if (-e "$vars_config{MembersPath}/$last_post_num.cgi") {
@user_profile = &OpenProfile($last_post_num);
chomp($user_profile[15]); chomp($user_profile[0]);
$last_post_username = $user_profile[15];
if ($user_profile[15] eq '') { $last_post_username = $user_profile[0]; }
}
else {
$last_post_username = $last_post[2];
}
my $total_posts = $total_replies + 1;
my $page_num = '';
if ($total_posts > $vars_display{HTMLDisplayMax}) {
my $total_pages = int ($total_posts / $vars_display{HTMLDisplayMax});
if ($total_posts % $vars_display{HTMLDisplayMax}) { $total_pages++; }
if ($total_pages > 1) {
$page_num = "&p=$total_pages";
}
}
$last_post_username = qq!
$vars_wordlets_mods{last_reply_by}: $last_post_username!;
} else {
$last_post_username = '';
}
}
# end last post hack

if anyone else gets this

edit: i think its a problem with the old "change username" hack i used, and with unregistered post
edit2: just making it easier to understand, i enclosed the code that opens the profile with an if that checks if the $last_post_num variable is not empty. when i entered the forum, there were some guests posts in the last posts (which not appeared in the topic listing).

Joined: Jan 2001
Posts: 1,940
Q
Developer
Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
SHW of this hack now available on my website: http://www.qasic.com/ubbhacks.html

Joined: Apr 2001
Posts: 21
A
Junior Member
Offline
Junior Member
A
Joined: Apr 2001
Posts: 21
I just apply the hack to my board and seems to work fine.
I don't get any "last reply by" or "by" i just get the username.....like in the picture.
how can i change it to "by:username"
i'm using ubb6.04c and i installed using lastreplyby202.shw
[Linked Image]

Joined: Mar 2001
Posts: 40
S
Member
Offline
Member
S
Joined: Mar 2001
Posts: 40
Newman try this
Quote
quote:

Joined: Apr 2001
Posts: 21
A
Junior Member
Offline
Junior Member
A
Joined: Apr 2001
Posts: 21
thanks i did installed the mods_wordlet and now is working fine !
Cheers !

Page 3 of 5 1 2 3 4 5

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
badfrog
badfrog
somewhere on the coast of Maine
Posts: 94
Joined: March 2007
Forum Statistics
Forums63
Topics37,557
Posts293,856
Members13,847
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,819
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 70
Gizmo 16
Brett 7
WebGuy 2
Morgan 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2021 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Snapshot build 20210915)
Responsive Width:

PHP: 7.3.29 Page Time: 0.047s Queries: 95 (0.028s) Memory: 0.9961 MB (Peak: 1.1956 MB) Data Comp: Zlib Server Time: 2021-12-06 14:54:49 UTC
Valid HTML 5 and Valid CSS