Previous Thread
Next Thread
Print Thread
Rate Thread
Page 4 of 4 1 2 3 4
Joined: Jan 2002
Posts: 63
Member
Member
Offline
Joined: Jan 2002
Posts: 63
does this help although i have tried to get this to work i cannot but hope this helps u xpert.
[code][/code]

Sponsored Links
Joined: Jan 2002
Posts: 63
Member
Member
Offline
Joined: Jan 2002
Posts: 63
hi qasic. i tried before to install this mod and had problems.
quote:
sry i might have explained that bit a little wrong, everything was uploaded fine, but in the cp the avatar manage and the one for uploading the avatars are there just the screens for them are empty. and in the my profiles section when i added it everything from: Your Picture:
Enter a link to a picture of yourself. This must be a complete URL. down was gone. i used backups and just took everything back out but i would really like this one.
just not sure what might be causeing the empty pages and that chunk of missing stuff in the my profiles.
hope this helps explain it a little better.

well after taking everything out and not doing anything for a bit i figured it was installer error so i tried to rehack this again fresh from the start.
i even found 1 or 2 things i missed the first time i hacked the files but to no avail.
i had the exact same problem again.
i get no errors anywhere but in the cp as before both places avatar manage and uploads avatar screens are blank no errors just a blank screen.
and when u go into my profile there is a whole chunk of code missing. but again still no errors it's just missing?
well i took everything out again wish i could have this but i take it that mabye my board won't have avatars this time around.

Joined: Jun 2001
Posts: 2,849
Spotlight Winner
Spotlight Winner
Offline
Joined: Jun 2001
Posts: 2,849
That fixed it, but why is it off in UBB 6.2.1.1? It wasn't off in other versions.

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Charles Capps implemented that change for UBB 6.2.x to increase security smile I've had to reverse back the change to allow the upgrades to go through. Hope that helps.

qasic

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
quote:
Originally posted by Nalina:
I recently upgraded ubb I admin to the newest version and so had to rehack and such .. I installed this hack .. seems to be working great but theres just one problem.

With the old version (we were on 6.02 a long time o.O; ) we had the avatar hack installed along with a addon I once found on here that allowed for a link to a picture on their own web space to be there too.

I still have the instructions for it, but since the avatar hack and ubb has changed so much I don't think it'll work.

Yeah I know there is the custom thing now with this version .. but .. with over gosh 5000 user names last I checked ... that would be a lotta images and a lotta work for the admin and mods.

Anyone out there who can help?

Hi Nalina,

Unfortunately, with that functionality (having external urls), people can steal your UBB login cookies simply by entering a URL that is a PHP/CGI script with an appended javascript command. This is partly the reason why I've decided not to allow external URLs in my version of the avatar hack.

However, you will be glad to know that UBB 6.3.x will not have such limitation smile

qasic

Sponsored Links
Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
deathdealer,

The case of missing parts in the Control Panel and the ultimatebb.cgi are often the as a result of ubb_avatar.cgi, cp_avatar.cgi, and cp_vars_avatar.pl not being uploaded. Were these uploaded in their correct places?

qasic

Joined: Jan 2002
Posts: 63
Member
Member
Offline
Joined: Jan 2002
Posts: 63
i'll check that again just to be sure and repost back with the results.

Joined: Jan 2002
Posts: 63
Member
Member
Offline
Joined: Jan 2002
Posts: 63
double double post post laugh

Joined: Apr 2001
Posts: 7
Junior Member
Junior Member
Offline
Joined: Apr 2001
Posts: 7
I doubt anyone on the forum would realize that ^.^ I'm counting on it ... LOL ... But merf... what a pain. URL avatars is heavily relied on. The populas is itching to get them back.

When is 6.3 to be realeased?

(Figures I'll have to go through the whole upgrade process again ...)

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
If security is not an issue, than I recommend you remove my avatar hack and install "External Avatar Hack" instead available from my site. Hope this helps.

qasic

Sponsored Links
Joined: Oct 2001
Posts: 157
Member
Member
Offline
Joined: Oct 2001
Posts: 157
On clicking the avatar list page, I am getting th efollowing error message:

quote:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

--------------------------------------------------------------------------------

Apache/1.3.19 Server at www.myhotboard.com Port 80

What could possibly be causing it?

v 6.2
Lots of hacks added and all working well.


Yors Truly

Who? Me? Worry?
Joined: Jan 2002
Posts: 63
Member
Member
Offline
Joined: Jan 2002
Posts: 63
iv'e tried everything took out all the avatar files them re added them chmoded them and still nothing.
so ill just go with your external avatar listing mabye that will work.

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
quote:
Originally posted by yors:
On clicking the avatar list page, I am getting th efollowing error message:

quote:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

--------------------------------------------------------------------------------

Apache/1.3.19 Server at www.myhotboard.com Port 80

What could possibly be causing it?

v 6.2
Lots of hacks added and all working well.

Most likely incorrect path to Perl at the top of avatarlist.cgi

qasic

Joined: Apr 2002
Posts: 2
Junior Member
Junior Member
Offline
Joined: Apr 2002
Posts: 2
I get this Java Script Err when Anybody wants to Choose a Avatars From the Drop Down Menu

(Error: 'document.forms.0.picture value is null or not an object) Anybody know what might Cause this???

Thanks For UR Time

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Incorrect hacking in public_edit_profile.pl

qasic

Joined: Apr 2002
Posts: 2
Junior Member
Junior Member
Offline
Joined: Apr 2002
Posts: 2
Oh yeah i forgot to mention That this hack has was working for weeks and i started to get this err about 3days ago ......... and ive hacked the file about 20times these past 3days .......is there a option in the CP that it might Mess up the hack??? if so i might have Turned it on/off???

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Turning pictures in profile off may be a problem.

qasic

Joined: Jun 2001
Posts: 56
Member
Member
Offline
Joined: Jun 2001
Posts: 56
qasic..
I can't get an avatar list to show when clicking on the ' Click here to see all available avatars' in My Profile..Drop down box just shows a straight line below 'None' All paths are correct when I configured it in the cpanel..All files were upped and CHMOD'ed correctly..No errors showing, just no avatar listings..And yes, I upped some avatars to may avatar folder..I have many mods added to my board..Might this be the problem?? I'm using 6.2.1.2 on a UNIX server...Any assistance here would be great..

Joined: May 2002
Posts: 3
Junior Member
Junior Member
Offline
Joined: May 2002
Posts: 3
Hi,
I'm very new with hacks... but i managed to install the hack without any problems, i thought...

I can't get the avatar show up with each post... All the settings are set correctly but that doesn't change anything. Can somebody help me?

(Sorry for my bad english, im dutch)

Joined: Mar 2002
Posts: 3
Junior Member
Junior Member
Offline
Joined: Mar 2002
Posts: 3
Qasic,

I tried to install Avatars, but when I update the control panel-avatars settings , it just show the following and no update action done, what's the problem ? I tried to upload the vars_avatars.cgi & vars_wordlet_avatars.cgi as you said, but still no work.. please suggest the solution of it , thank you very much confused !!!
========================================
You did not complete all required fields.
You did not complete: avatar_field
You did not complete: avatar_explain
You did not complete: custom_avatar
You did not complete: avatar_list_tab
You did not complete: avatar_num
You did not complete: list_explain
You did not complete: pages
You did not complete: list_text
You did not complete: select_none
You did not complete: select_custom
You did not complete: close_window
You did not complete: img_types
=========================================

Joined: Jul 2001
Posts: 808
Coder
Coder
Joined: Jul 2001
Posts: 808
I use avatar_hack_v1_2_62.zip on Ultimate Bulletin BoardTM 6.2.1.2. It works well but my Mod's are not able to access the avatar maintance panel to upload new avatars. I set this function to on in the avatar control panel but access to the maintance of avatars is restrictet.

I read the thread but found nothing about this. Can you give me a clue ? Thanks.

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
double-check your work in cp.cgi to make sure you've done that correctly.


- Allen wavey
- What Drives You?
Joined: Jul 2001
Posts: 808
Coder
Coder
Joined: Jul 2001
Posts: 808
my fault frown but not in cp.cgi smile I miss this:

quote:

cp_common.pl (template)
FIND (this occurs TWICE; do this hack TWICE)

now it work

Joined: Jul 2001
Posts: 808
Coder
Coder
Joined: Jul 2001
Posts: 808
now, I can access the controlpanel and go to the upload requester as mod. But if I try to send something the controlpanel return to main windows and tell me:

You do not have permission to access this area.
ยป Use your browser's back button to return.

chmod seems to be right and I cant find any mistake in my hacks. but I will continue to check it. Any idea where I can search ? Upload as Admin works well.

Edit:

this section of hacking can't be done:
[code][/code]If I try this I will get an error from my server so I leave this line as is.

Joined: Jul 2002
Posts: 2
Junior Member
Junior Member
Offline
Joined: Jul 2002
Posts: 2
You do not have permission to access this area.
that is what i am told when i go into my controll panel/primary settings/avatar
using ubb6.2.1
whats wrong?

Joined: May 2001
Posts: 6,708
Member
Member
Offline
Joined: May 2001
Posts: 6,708
Did you set all your file permissions correctly?

Did you hack cp.cgi correctly?

Joined: Jul 2002
Posts: 2
Junior Member
Junior Member
Offline
Joined: Jul 2002
Posts: 2
quote:
Originally posted by Lord Dexter:
Did you set all your file permissions correctly?

Did you hack cp.cgi correctly?

ahhhhhgh, cp.cgi not hacked properly, thanks.

Joined: Jul 2001
Posts: 808
Coder
Coder
Joined: Jul 2001
Posts: 808
any Idea for my problem ? (points 4 posts up). Mod's can access the control panel of avatars but are not able to upload new avatars. Permissions double checked, seems to be ok

Joined: May 2002
Posts: 4
Junior Member
Junior Member
Offline
Joined: May 2002
Posts: 4
I seem to be having a huge problem with this on a 6.2.1.0 The hack uploads fine, everything is set properly, permissions are set great. But whenever someone goes to select an avatar, it lets them chose it and preview it, but when they click submit it says that a hack attempt has been logged.

I've rehacked EVERY file at least 6-7 times over now, and also used the autoinstall and it doesnt work either...

frown Help?

Page 4 of 4 1 2 3 4

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
hatter
hatter
USA
Posts: 69
Joined: January 2001
Forum Statistics
Forums63
Topics37,573
Posts293,925
Members13,849
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,833
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 82
Gizmo 20
Brett 7
WebGuy 2
Morgan 2
Top Likes Received (30 Days)
isaac 1
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2023 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Preview build 20221218)