Previous Thread
Next Thread
Print Thread
Rate Thread
Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Name: Avatar Hack Importer

Requirements: Any UBB 6.1x (or higher) based Qasic.NET avatar hack, UBB 6.3.0 relase beta 1.0 or higher

Description: This program will import all your Qasic.NET avatar hack settings into UBB 6.3.0. It will clean all previously set URL settings, move your avatars to their new directories as required in UBB 6.3, and update your members' profiles' avatar settings automatically.

Download URL: http://www.qasic.net/main.cgi?action=details;file=avimport

Notes Addendum: This marks the end of the line for the Qasic.NET Avatar Hack although we reserve the right to expand upon Infopop's functionality smile

As always, bug reports are gladly received.

qasic

Sponsored Links
Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
You know people need to start using this smile

qasic

Joined: Jan 2001
Posts: 38
Member
Member
Offline
Joined: Jan 2001
Posts: 38
So we have to update the the board to 6.3 beta and then use that? But when updating to 6.3 won't that mess up the already hacked parts or that doesn't matter? (That probably makes no sense whatsoever)

Also with 6.3 beta are we allowed to have the custom avatar option so that any member can't choose somebody's personalized avatar?

Joined: Jun 2001
Posts: 572
Member
Member
Offline
Joined: Jun 2001
Posts: 572
quote:
Originally posted by Eliza:
Also with 6.3 beta are we allowed to have the custom avatar option so that any member can't choose somebody's personalized avatar?

Yes. People can put in a URL to an image that they want their avatar to be and they can use that. smile

~Jon

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
quote:

So we have to update the the board to 6.3 beta and then use that? But when updating to 6.3 won't that mess up the already hacked parts or that doesn't matter? (That probably makes no sense whatsoever)

Excellent question Eliza. Yes, upgrade to UBB 6.3.x before using this program. Don't worry - your previous avatar settings won't be lost when you upgrade your UBB because the settings are stored in files that are not overwriten by the UBB 6.3.x upgrade.

Please LMK if you have any other questions.

qasic

Sponsored Links
Joined: Jan 2001
Posts: 38
Member
Member
Offline
Joined: Jan 2001
Posts: 38
I got this:

Expires: Expires: Mon, 26 Jul 1997 05:00:00 GMT Date: Sat, 20 Apr 2002 14:42:32 GMT Pragma: no-cache Cache-control: no-cache, must-revalidate Last-modified: Sat, 20 Apr 2002 14:42:32 GMT Content-Type: text/html Avatar Import for UBB 6.3.x - error
.
unable to open /home/caringboard/ubb/cache-
C45YS8M4/avatar_import/delete for spooling at avatar_import.cgi line 864.

(Caller: avatar_import.cgi:973 -> sub main::Tracer)
(Caller: Carp.pm:139 -> sub main::error_output)
(Caller: Carp.pm:82 -> sub UBBCGI::Carp::fatalsToBrowser)
(Caller: avatar_import.cgi:864 -> sub UBBCGI::Carp::die)
(Caller: avatar_import.cgi:258 -> sub main::WriteFileAsString)
(Caller: avatar_import.cgi:44 -> sub main::step1)

I don't think it was suposed to do this? I'm not sure though.

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Hi Eliza,

Yup you should not be getting that error. Here's the fix:

find:

Code
[/code]and ADD below:

[code]
That should do the trick for you. FYI, it's wise to back up vars_avatar.cgi and vars_wordlets_avatar.cgi smile

My ZIP file has been silently updated to take into account this fix.

qasic

Joined: Jan 2001
Posts: 38
Member
Member
Offline
Joined: Jan 2001
Posts: 38
It works qasic!!! Thanks a bunch!!

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Thank you for notifying me Eliza!

qasic

Joined: Apr 2001
Posts: 7
Junior Member
Junior Member
Offline
Joined: Apr 2001
Posts: 7
Um uh ... Just installed new ubb and I uploaded this up in ascii and chmodded it .. and I have rechecked em' several times .. its running on a Unix system .. but .. it .. doesn't do anything. IE just gets a blank page and Netscape says theres no data. *sweatdrops* I know the server has soooo many things disabled its nuts (I can't even SSH Telnet up .. let alone telnet or any of that o.O; ) and our server admin seems to be highly elusive.

Will the setting in members profiles cause problems? or is it okay? .. I still have the board disabled so I'm lil' nervous about reenabling it ... I had to edit my profile file since CP seems to have gained a check for any odd stuff in a profile file and wouldn't let me into the cp till I fixed it. smirk

Sponsored Links
Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
1) Make sure your UBB 6.3.x is functioning fine before applying this hack.

2) Check the error logs for any error messages these files may be outputting.

qasic

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
*This thread needs moving wink *

Joined: Mar 2001
Posts: 136
Journeyman
Journeyman
Offline
Joined: Mar 2001
Posts: 136
I am getting blank page too.

my UBB is on my own machine.

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Have you been able to check your error logs to see if the Perl outputs any errors?

qasic

Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
Great to see my name in the hack, thanks smile

Joined: Oct 2001
Posts: 32
Content King
Content King
Offline
Joined: Oct 2001
Posts: 32
Qasic, everything worked, except the people with custom avatars can't choose their custom =/

DId I do something wrong or is the hack not designed to have customs carried over?

Joined: May 2001
Posts: 794
Content Queen
Content Queen
Offline
Joined: May 2001
Posts: 794
quote:
Originally posted by Gideon:
Qasic, everything worked, except the people with custom avatars can't choose their custom =/

DId I do something wrong or is the hack not designed to have customs carried over?

This is my question, too! laugh

I don't want my members to link to an outside picture (they'll do that nasty direct linking to other sites because they won't know any better).

Plus, we really identify one another by our avatars and strive to have unique ones for those who "register them."


Sue
adwoff.com
Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Custom avatars linked to an outside source (outside your custom directory) will automatically be removed. Custom avatars in the custom directory should be transferred.

This was done in my last avatar hack for UBB 6.2.x to eliminate a security bug. UBB 6.3.x will permit this without any problems.

qasic

Joined: Oct 2001
Posts: 32
Content King
Content King
Offline
Joined: Oct 2001
Posts: 32
Thanks qasic, everythign works great now!

Joined: Apr 2001
Posts: 1
Junior Member
Junior Member
Offline
Joined: Apr 2001
Posts: 1
I have the same problem with the blank page when trying to run avatar_import.cgi. Here's the error message from the Apache errorlog:

Can't locate HTTP/Date.pm in @INC (@INC contains: ./ ./Modules /apache/cgi-bin /apache/cgi-bin/Modules /usr/lib/perl5/5.00503/i386-linux /usr/lib/perl5/5.00503 /usr/lib/perl5/site_perl/5.005/i386-linux /usr/lib/perl5/site_perl/5.005 .) at /apache/cgi-bin/avatar_import.cgi line 880.

Thanks.

Joined: May 2001
Posts: 794
Content Queen
Content Queen
Offline
Joined: May 2001
Posts: 794
When I run the avatar_import.cgi file, I get this message:

quote:
NOTE: Problems exist in your Avatar Installation. Please fix this problem before you run this utility.

---------------------------------------------------
Paths in vars_avatar.cgi do not exist
---------------------------------------------------

Guidance would be very appreciated. laugh


Sue
adwoff.com
Joined: Mar 2001
Posts: 80
Member
Member
Offline
Joined: Mar 2001
Posts: 80
Hi, I am getting this error.
[code][/code]I am calling it from a browser window that is logged into the cp.

Any ideas?

Paul

Joined: May 2001
Posts: 794
Content Queen
Content Queen
Offline
Joined: May 2001
Posts: 794
Since I'm getting closer and closer to the point where I am going to upgrade my main board, I thought I'd revisit this.

Avatars are very important at my community; I really need for the custom avatars to transfer over ... and to be able to do custom avatars in the future.

Any help offered would be most appreciated.

Thanks!

quote:
Originally posted by ADWOFF:
When I run the avatar_import.cgi file, I get this message:

quote:
NOTE: Problems exist in your Avatar Installation. Please fix this problem before you run this utility.

---------------------------------------------------
Paths in vars_avatar.cgi do not exist
---------------------------------------------------

Guidance would be very appreciated. laugh


Sue
adwoff.com
Joined: Feb 2000
Posts: 59
Member
Member
Offline
Joined: Feb 2000
Posts: 59
All I get is a blank page as well when I try to run the script. frown

Joined: Aug 2001
Posts: 50
Member
Member
Offline
Joined: Aug 2001
Posts: 50
My test site is at: http://www.farts.com/cgi-bin/ubb/ultimatebb.cgi

I am getting a blank page when I try to run the script. My error log is as follows:
quote:
Can't locate HTTP/Date.pm in @INC (@INC contains: ./ ./Modules /home/sites/www.farts.com/web/cgi-bin/ubb /home/sites/www.farts.com/web/cgi-bin/ubb/Modules /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at /home/sites/www.farts.com/web/cgi-bin/ubb/avatar_import.cgi line 880.
Line 880 of the script is:
require HTTP::Date;

Any help would be appreciated!

Joined: Aug 2001
Posts: 50
Member
Member
Offline
Joined: Aug 2001
Posts: 50
Further Troubleshooting:

I changed line 880 to read:

USE HTTP::Date;

I now get the following errors: (these errors are ALMOST identical to above, however I actually see the errors being generated on the page itself instead of getting a blank page:

Software error:
Can't locate HTTP/Date.pm in @INC (@INC contains: ./ ./Modules /home/sites/www.farts.com/web/cgi-bin/ubb /home/sites/www.farts.com/web/cgi-bin/ubb/Modules /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at /home/sites/www.farts.com/web/cgi-bin/ubb/avatar_import.cgi line 880.
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Wed Jun 26 10:11:09 2002] Date.pm: Can't locate HTTP/Date.pm in @INC (@INC contains: ./ ./Modules /home/sites/www.farts.com/web/cgi-bin/ubb /home/sites/www.farts.com/web/cgi-bin/ubb/Modules /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at /home/sites/www.farts.com/web/cgi-bin/ubb/avatar_import.cgi line 880. BEGIN failed--compilation aborted at /home/sites/www.farts.com/web/cgi-bin/ubb/avatar_import.cgi line 880.
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error.

Joined: Aug 2001
Posts: 50
Member
Member
Offline
Joined: Aug 2001
Posts: 50
My trouble has been fixed.

The trouble was with the perl module HTTP::Date

For anyone else getting a blank screen when trying to run this script, 1 of two things is the problem

1. - you dont have the HTTP::Date perl module installed on your server or
2. - the module is configured incorrectly.

The quickest way to determine if you have this module installed is to telnet into your server and issue this command:
perl -mHTTP::Date

If you get an error of any kind that is where the trouble lies.

-------------------------------
Problem #2

My avatar directory name did not change. (my original avatar directory was "Avatars" so the script doesnt need to move anything.
The script locked up while trying to move the avatars.

I checked the board and every member file had the picture field changed to blank, but it did not place the correct avatar in the avatar field - meaning every profile now does not have an avatar selected. Lovely.

I reran the script and it completed sucessfully but didnt fix the problem

Joined: Feb 2002
Posts: 8
Junior Member
Junior Member
Offline
Joined: Feb 2002
Posts: 8
Hi,

I want to upgrade my ubb from version 6.1.0.4 to 6.5.0 I have installed Qasic Avatar Hack, my question is if this hack (Avatar Importer) works with version 6.5.0

Thanks,

Carlos


Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Bill B
Bill B
Issaquah, WA
Posts: 87
Joined: December 2001
Forum Statistics
Forums63
Topics37,574
Posts293,926
Members13,850
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,833
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 82
Gizmo 20
Brett 7
WebGuy 2
Morgan 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2024 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Preview build 20240506)