Previous Thread
Next Thread
Print Thread
Rate Thread
#219609 06/22/2002 11:27 PM
Joined: Jan 2002
Posts: 218
Enthusiast
Enthusiast
Offline
Joined: Jan 2002
Posts: 218
Mod Name / Version: AutoQuote v2.0

Link: http://www.terranbbs.com/ubb/mods/6.0/AutoQuote.txt

Description: Allow your users to reply to a message while quoting someone. Lets the user just click on a link/icon and it will automatically put the tags around the body of the message that they want to quote.

Working under: UBB.threads v6.0 & 6.0.1

Pre-requisites: None

Author(s): WrÅith

Credits: AllenAyers, poil, and razvan for getting me started, and JustDave for helping me with the bug fixes.

Demo: http://www.terranbbs.com/testboard/ubbthreads.php (Username: test / Password: test)

Files Altered: newreply.php, newreply.tmpl, showflat.php, showflat.tmpl, showthreaded.php, showthreaded.tmpl, ubbt.inc.php, /language/english/generic.php

Database Altered: No

New Files: None

Additional Information: None

Sponsored Links
SDS #219610 07/01/2002 12:58 AM
Joined: Feb 2001
Posts: 2,268
Junior Member
Junior Member
Offline
Joined: Feb 2001
Posts: 2,268
I found some errors with the AutoQuote instructions. Since I couldn't post to this thread over the weekend due to database errors you can find the details here. Thanks!

jacksonm99 #219611 07/01/2002 10:05 AM
Joined: Jan 2002
Posts: 218
Enthusiast
Enthusiast
Offline
Joined: Jan 2002
Posts: 218
I've updated the instructions. The lines that you are looking for are located at lines 569 and 661 in an unmodified version of ubbt.inc.php.

SDS #219612 07/10/2002 2:36 AM
Joined: Mar 2002
Posts: 2
Lurker
Lurker
Offline
Joined: Mar 2002
Posts: 2
I've installed this hack on my 6.0.2 forums and all seemd to be fine with it. It works fine in "flat" mode, I can "quote" a reply, but when I went to "threaded" mode, the word quote isn't a hyperlink like it is when in flat mode. the word quote shows up, the quote image shows up, but I can't click on quote to quote a reply. Any suggestions, I'm a relative "noob" with threads, but have used and hacked many a UBB Classic and Vbulletin forum on my site.

xballad #219613 07/10/2002 2:46 AM
Joined: Jan 2002
Posts: 218
Enthusiast
Enthusiast
Offline
Joined: Jan 2002
Posts: 218
Make sure you follow PART FIVE. Looks like you left out Step 2 which formats the image and the text into a link.

Sponsored Links
SDS #219614 07/10/2002 12:58 PM
Joined: Mar 2002
Posts: 2
Lurker
Lurker
Offline
Joined: Mar 2002
Posts: 2
DOH! Now I know why I shouldn't answer the phone when in the middle of applying even a simple hack..... thanks for the reply....

xballad #219615 08/28/2002 8:37 PM
Joined: Feb 2002
Posts: 1,759
Addict
Addict
Offline
Joined: Feb 2002
Posts: 1,759
any update on if this works with 6.1 beta? My users are complaining, they miss the quick quote feature.

palmen #219616 08/29/2002 1:08 AM
Joined: Jan 2002
Posts: 218
Enthusiast
Enthusiast
Offline
Joined: Jan 2002
Posts: 218
I'm waiting until the final version of 6.1 is released before I invest time in re-writing this. The only reason is, I've been screwed in the past when code was changed significantly from one beta version to the next and I don't want to have to rewrite this twice.

Yeah, I know, I'm lazy.

palmen #219617 08/29/2002 4:28 PM
Joined: Aug 2002
Posts: 239
Member
Member
Joined: Aug 2002
Posts: 239
It does work just fine with the beta....Running it over at http://stormchat.com/ubbthreads No problems at all yet.....

posted by msula:
any update on if this works with 6.1 beta? My users are complaining, they miss the quick quote feature.


Some people read their stars..... I choose to write my own
#219618 09/13/2002 5:58 PM
Joined: Jun 2002
Posts: 375
Enthusiast
Enthusiast
Offline
Joined: Jun 2002
Posts: 375
Yeah this v2.0 works on the 6.1 beta. Don't use the v2.0.2 that is floating around these boards somewhere, as it does NOT work on 6.1

Sponsored Links
neuron #219619 09/13/2002 10:43 PM
Joined: Jan 2002
Posts: 218
Enthusiast
Enthusiast
Offline
Joined: Jan 2002
Posts: 218
[]Yeah this v2.0 works on the 6.1 beta. Don't use the v2.0.2 that is floating around these boards somewhere, as it does NOT work on 6.1

Glad to hear it works. I haven't had a chance to do any testing on v6.1. I plan on upgrading my testboard this weekend, however. I think I'm going to just install a clean version and then reapply the various hacks that I have installed. I think in the long-run it'll be easier that way.

SDS #219620 09/13/2002 11:29 PM
Joined: Jun 2002
Posts: 375
Enthusiast
Enthusiast
Offline
Joined: Jun 2002
Posts: 375
That's what I've been doing for two days now. Got most of the hacks I use running fine on 6.1 except for the calendar hack, which I'm stuck on the upgrading of.

neuron #219621 09/13/2002 11:42 PM
Joined: Aug 2002
Posts: 239
Member
Member
Joined: Aug 2002
Posts: 239
Hey Wraith, Is there any way to limit the amount of quotes on one post?? I love autoquote but it got to be too much fun for the users playing an seeing how long a quote they could do. And also, when the quotes do get too long it's not wrapping the lines of the box and it causes folks to have to scroll right to see the entire post. Is there a way to handle that?? BTW, notice I said..... I love AutoQuote.....hehe


Some people read their stars..... I choose to write my own
#219622 09/14/2002 12:37 AM
Joined: Jun 2002
Posts: 375
Enthusiast
Enthusiast
Offline
Joined: Jun 2002
Posts: 375
The autoQuote does place a <blockquote> tag in each time, so those could be counted and if a preset limit is already reached, don't let them quote again. Just shoot them an error instead.

#219623 09/25/2002 2:15 PM
Joined: Jan 2002
Posts: 218
Enthusiast
Enthusiast
Offline
Joined: Jan 2002
Posts: 218
Sorry it's taken me so long to respond on this one. I've been away for a while. I think that it might be possible to count the number of <blockquote> tags; however, other codes also use the <blockquote> and it may give a false reading. What you really need is some sort of iterative counter, though how that would be implemented is a bit beyond me.

I haven't had a chance to upgrade to 6.1 yet. Hopefully I will have some time this evening to at least get my testboard up and running. I'll see what I can do and post any updates in the Beta forum.

SDS #219624 09/25/2002 4:48 PM
Joined: Aug 2002
Posts: 239
Member
Member
Joined: Aug 2002
Posts: 239
No problem Wraith...... Thanks!! I look forward to it!!


Some people read their stars..... I choose to write my own
SDS #219625 09/28/2002 10:28 AM
Joined: Feb 2001
Posts: 2,268
Junior Member
Junior Member
Offline
Joined: Feb 2001
Posts: 2,268
I'm having a tough time getting the auto quote hack to work with 6.1 final. Part 7 3a does not exist in the ubbt.inc.php file (I'm using the original,unmodified file).

Thanks in advance to anyone who lends me a hand, my users really like this hack!

jacksonm99 #219626 09/28/2002 3:49 PM
Joined: Feb 2002
Posts: 1,759
Addict
Addict
Offline
Joined: Feb 2002
Posts: 1,759
I have it working just fine on my 6.1 final. Hmm...

palmen #219627 09/28/2002 5:08 PM
Joined: Aug 2002
Posts: 239
Member
Member
Joined: Aug 2002
Posts: 239
Hey Msula....

I was lookin' around your site and couldn't find anywhere that people are using the autoquote more than once in thread / post. I tried it before at my site and the folks loved it. However, I had a problem with them using it over and over to play games so that posts were a full page long and causing people to have to scroll right..... Did you find a way around this problem or are the people there just more mature?


Some people read their stars..... I choose to write my own
#219628 09/28/2002 6:44 PM
Joined: Feb 2002
Posts: 1,759
Addict
Addict
Offline
Joined: Feb 2002
Posts: 1,759
We had one thread where someone discovered the neat effect of the quote with a quote within a quote feature.. I let it go on to see the limits, and eventually deleted the thread and informed them not to do it again.

So far they have been behaved

palmen #219629 09/28/2002 6:46 PM
Joined: Aug 2002
Posts: 239
Member
Member
Joined: Aug 2002
Posts: 239
I reckon that's what I'll try this time....... Puttin' it back in 'cuz I miss it myself......


Some people read their stars..... I choose to write my own
palmen #219630 09/29/2002 11:22 AM
Joined: Feb 2001
Posts: 2,268
Junior Member
Junior Member
Offline
Joined: Feb 2001
Posts: 2,268
I followed the directions and got html tags in the quote area of a reply, plus the ubbt.inc.php instructions didn't match the script in the ubbt.inc.php file.

I'll try it again later on today and see if there was anything that I missed (already tried it twice).

Last edited by Dalantech; 09/29/2002 11:23 AM.
palmen #219631 09/29/2002 11:43 AM
Joined: Feb 2001
Posts: 2,268
Junior Member
Junior Member
Offline
Joined: Feb 2001
Posts: 2,268
Nevermind, I got it to work

jacksonm99 #219632 09/30/2002 6:27 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Mind sharing any changes you may have made?


- Allen wavey
- What Drives You?
Joined: Feb 2001
Posts: 2,268
Junior Member
Junior Member
Offline
Joined: Feb 2001
Posts: 2,268
I used another set of instructions that I had from Wraith. I'm not sure if they are different, and in the comments both have the same date, but it was the instructions that I used the first time I did the auto quote hack.

I also pulled the files I needed to hack out of the 6.1 zip so I had a "clean" copy to work with.

The ubbt.inc.php instructions still don't match up, but I replaced the two "quote markup" sections with text from the auto quote instructions.

I also did the editting in CuteHTML a little differently when I got the hack to work. I stopped using the built in find and replace and took a couple more steps. I might be seeing a bug in CuteHTML.

Last edited by Dalantech; 10/01/2002 2:14 AM.
jacksonm99 #219634 10/01/2002 6:56 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Anyone else getting errors with polls and this?


- Allen wavey
- What Drives You?
SurfMinister #219635 10/01/2002 11:06 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
view this with a poll in threaded view


- Allen wavey
- What Drives You?
Joined: Feb 2001
Posts: 2,268
Junior Member
Junior Member
Offline
Joined: Feb 2001
Posts: 2,268
I'm not seeing any errors with polls on my site and the auto quote seems to be stable.

I'm not using Bookie's Blam templates though, I'm "rolling my own"

SDS #219637 11/03/2002 3:07 PM
Joined: Feb 2002
Posts: 91
Journeyman
Journeyman
Offline
Joined: Feb 2002
Posts: 91
I like the quote, thanks for your efforts.

Here is some thing I have noticed.

If someone quotes a post that has a poll in in, the poll code is displayed, like this:

<FORM METHOD=POST ................</form>

I took everything out between the form tags to keep it short.

Maybe it would be best to strip polls out of quoted posts?


-------------
Youuuuuuuuuuu Rang?
#219638 11/03/2002 5:03 PM
Joined: Feb 2002
Posts: 91
Journeyman
Journeyman
Offline
Joined: Feb 2002
Posts: 91
I went ahead and changed newreply to strip out polls.

It took care of form code being displayed in quoted messages and the poll's no longer get send out in emails.


-------------
Youuuuuuuuuuu Rang?
#219639 11/11/2002 8:18 PM
Joined: Oct 2002
Posts: 24
Junior Member
Junior Member
Offline
Joined: Oct 2002
Posts: 24
Installed quotes and now when u hit quote button

you get this

{qoute=username}quoted text


___________________

new text

what is wrong?

bud #219640 01/06/2003 2:51 PM
Joined: Nov 2001
Posts: 126
Junior Member
Junior Member
Offline
Joined: Nov 2001
Posts: 126
Heres a better question...

Can someone figure out how to get back "quoted by username" in 6.2?

It doesnt do that anymore and is quite annoying because you have to scroll back up to find the quote.. and in a 100 + reply message.. it can get tedious.

(PS: 6.2 is great, just small things, ya know )

nonomen #219641 01/09/2003 6:00 PM
Joined: Jul 2002
Posts: 1
Lurker
Lurker
Offline
Joined: Jul 2002
Posts: 1
[]Heres a better question...

Can someone figure out how to get back "quoted by username" in 6.2?
[/]

See In Reply To fix for 6.2

Marc

SwedeB #219642 01/09/2003 10:44 PM
Joined: Nov 2001
Posts: 10,369
I type Like navaho
I type Like navaho
Joined: Nov 2001
Posts: 10,369
Here is how to add the "Username said:" to your quote function.

Here is how to restore the [Re: Username] in showflat mode.


Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Bill B
Bill B
Issaquah, WA
Posts: 87
Joined: December 2001
Forum Statistics
Forums63
Topics37,573
Posts293,925
Members13,849
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,833
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 82
Gizmo 20
Brett 7
WebGuy 2
Morgan 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2024 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Preview build 20221218)