Previous Thread
Next Thread
Print Thread
Rate Thread
#44736 01/27/2003 6:11 PM
Joined: Oct 2001
Posts: 34
R
Member
OP Offline
Member
R
Joined: Oct 2001
Posts: 34
I currently have images turned off for members signatures. I also have the signature limit set to 150 characters. I know that by allowing images in signatures I run the risk of some members cluttering the threads with graphics. Some of which might be questionable.

Is there a way to keep the images turned off (so no "outside" graphics could be linked) and only let the smilies be included in members signatures? Or perhaps only let images from a certain directory be included in the signatures?

I'm running version 5.47e. I know that it's an oldie, but I hate to upgrade now after all the hacks I have installed and finally getting it to look just the way I want.

Any help is greatly appreciated...

Sponsored Links
#44737 01/27/2003 6:59 PM
Joined: Dec 2000
Posts: 730
J
deutscher moderator / v5 specialist
Offline
deutscher moderator / v5 specialist
J
Joined: Dec 2000
Posts: 730
Yes, there is.
I can post the code this week. Today, it's too late to search the code...

#44738 01/27/2003 8:06 PM
Joined: Feb 2000
Posts: 2,668
D
Deb Offline
Pooh-Bah
Offline
Pooh-Bah
D
Joined: Feb 2000
Posts: 2,668
Hi Greg, if you have posting icons turned on your users could just use the UBB Code img tags. Joking-down's code will be better ... but this might be a quick fix until he has time.


- Deb
#44739 01/29/2003 2:19 AM
Joined: Oct 2001
Posts: 34
R
Member
OP Offline
Member
R
Joined: Oct 2001
Posts: 34
joking-down,

Thanks, that would be great! I'll check back here later on this weekend.

Deb,

The posting icons are turned on and I tried the UBB image tags, but the images did not show up. Only the actual code showed up in its place.

#44740 01/30/2003 3:30 PM
Joined: Dec 2000
Posts: 730
J
deutscher moderator / v5 specialist
Offline
deutscher moderator / v5 specialist
J
Joined: Dec 2000
Posts: 730
reloadbench,


here is the code to allow only Image from your own domain in the signature (set AllowSignatureImage to yes):

[Linked Image] backup ubbmisc.cgi and ubb_library.pl.

[code][/code]change both my-domain.com in checkSigImage to your domainname!

Sponsored Links
#44741 02/01/2003 10:44 AM
Joined: Oct 2001
Posts: 34
R
Member
OP Offline
Member
R
Joined: Oct 2001
Posts: 34
joking-down,

Thanks for the code. I will add it today, hopefully without any problems. I'll let you know how it works.

Thanks again for your help!

#44742 02/01/2003 2:17 PM
Joined: Oct 2001
Posts: 34
R
Member
OP Offline
Member
R
Joined: Oct 2001
Posts: 34
joking-down,

I've followed the code to the letter and yet I can't get it to work.

I replaced the only two occurrences of the code in ubbmisc.cgi, and inserted the other string of code into ubb_library.pl just before the last line as directed. I also changed the my-domain to my own.

When the Control Panel settings for Signature Images is set to "NO" and I make a post, all I get is the URL of the image between the IMG tags. No image is displayed. With this CP setting the member file is written to and the UBB IMG tags are shown for the signature image.

When the Control Panel settings for Signature Images is set to "YES" and I make a post, the image appears in the signature. However, when you change the signature to include an image outside of my domain name, that "outside" image also appears in the signature. With this CP setting the member file is written to and the HTML tags are shown for the signature image.

Any idea's?

PS When you edit the post, regardless of what domain the image is located on, the signature image shows up...

#44743 02/06/2003 1:42 PM
Joined: Dec 2000
Posts: 730
J
deutscher moderator / v5 specialist
Offline
deutscher moderator / v5 specialist
J
Joined: Dec 2000
Posts: 730
I found the error.

[code][/code]the wrong image location would be deleted now.

#44744 02/07/2003 12:12 PM
Joined: Oct 2001
Posts: 34
R
Member
OP Offline
Member
R
Joined: Oct 2001
Posts: 34
joking-down,

Thanks,

I'll give that a try and post the results.

#44745 02/07/2003 12:31 PM
Joined: Oct 2001
Posts: 34
R
Member
OP Offline
Member
R
Joined: Oct 2001
Posts: 34
joking-down,

Thank you very much for your help. That additional bit of code worked perfectly and is greatly appreciated.

Sponsored Links

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
badfrog
badfrog
somewhere on the coast of Maine
Posts: 94
Joined: March 2007
Forum Statistics
Forums63
Topics37,557
Posts293,856
Members13,847
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,819
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 70
Gizmo 16
Brett 7
WebGuy 2
Morgan 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2021 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Snapshot build 20210915)
Responsive Width:

PHP: 7.3.29 Page Time: 0.022s Queries: 34 (0.012s) Memory: 0.8270 MB (Peak: 0.8845 MB) Data Comp: Zlib Server Time: 2021-12-02 09:26:59 UTC
Valid HTML 5 and Valid CSS