Previous Thread
Next Thread
Print Thread
Rate Thread
Page 2 of 4 1 2 3 4

Joined: Jun 2001
Posts: 216
C
Member
Offline
Member
C
Joined: Jun 2001
Posts: 216
Hello Qasic,
Thanks again for the hack -- works great on 6.2.1.

However, a bug exists in install text and should read as follows:

Q) Whenever my users post, the text on the right hand column of the table
is centered (i.e., vertical alignment is center). How can I fix that?
A) This is the default UBB behaviour but if you'll like to fix it, open up
public_topic_page.pl in your Templates directory (fix courtesy of Scats).
--------------------------------------------------------------------------------
Find the following line (around line 136):

Replace it with:

Find the following line:

Replace it with:

Find the following lines (around lines 156-158):
$post_body



After the tag, close the cell and open a new one:
$post_body




--------------------------------------------------------------------------------
Save and re-upload to Templates directory.
Sponsored Links
Joined: Feb 2002
Posts: 42
T
Member
Offline
Member
T
Joined: Feb 2002
Posts: 42
I installed using installer and i am getting
FYI
quote:
You do not have permission to access this area.

When i try to access the avatar CP
Is this because i used the installer, I know you said it's unsupported sorry but has anyone else had this problem.

Joined: Mar 2001
Posts: 7,394
L
LK Offline
Admin / Code Breaker
Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
Hack cp.cgi (manually)

Joined: Feb 2002
Posts: 42
T
Member
Offline
Member
T
Joined: Feb 2002
Posts: 42
Ok thanx i had a feeling i would have to do that. Oh well never mind Cut & Paste here i come. smile

Joined: Sep 2000
Posts: 159
E
Member
Offline
Member
E
Joined: Sep 2000
Posts: 159
Has anyone figured out how to fix it so that we can upload through the control panel? I would appreciate any help possible here. Thanks.

Sponsored Links
Joined: Oct 2001
Posts: 199
R
Member
Offline
Member
R
Joined: Oct 2001
Posts: 199
Hi,

Got this in on my 6.2.1 board and seems to work fine. One problem I'm having is that in cp when I'm in Avatar Settings and then select Update Avatar Settings I get an error message:

quote:

You did not complete all required fields.
You did not complete: close_window

» Use your browser's back button to return.

I only have sticky threads installed for hacks.

Any ideas?

Thanks

Rainner

Joined: Dec 2001
Posts: 51
M
Member
Offline
Member
M
Joined: Dec 2001
Posts: 51
quote:
Originally posted by Jbeset:
I'm waiting for a addon so users can put their own url in it. Are you going to release it or somebody else?

Shouldn't be so hard?
Newayz, good thinking, JB.
Maybe I'll try to, my CGI is developing very good smile

my_profile, register pages and public topic page should probraly have to be edited smile

Joined: Jan 2002
Posts: 34
J
Junior Member
Offline
Junior Member
J
Joined: Jan 2002
Posts: 34
quote:
Originally posted by GotaN:
quote:
Originally posted by Jbeset:
I'm waiting for a addon so users can put their own url in it. Are you going to release it or somebody else?

Shouldn't be so hard?
Newayz, good thinking, JB.
Maybe I'll try to, my CGI is developing very good smile

my_profile, register pages and public topic page should probraly have to be edited smile

Think so. Hope someone is going to release it cause i noticed too late on the 6.0x series...i made one by myself on those. But there was one allready

Joined: May 2001
Posts: 34
P
Member
Offline
Member
P
Joined: May 2001
Posts: 34
Custom Part of Hack.......

Sorry......found the answer in FAQ.....

Panda

Joined: Apr 2001
Posts: 18
M
Junior Member
Offline
Junior Member
M
Joined: Apr 2001
Posts: 18
Hello,

I have a poll posted at: http://www.visive.com/ubbcgi/ultimatebb.cgi?ubb=get_topic;f=9;t=000032

and get the error of:

Error
An error has occured:

Can't find string terminator ")" anywhere before EOF at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 181.

Please inform the board administration of this error so that they may fix the problem. Thank you!

-------------------------------------------------

This only happens once, when you hit refresh it directs you to the poll topic - or at least until the cache is cleared.

Is there a way to fix this?

Thank You smile

Sponsored Links
Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Metamorpheus,

That error usually occurs when one of your members has a funky URL (usually something like .cgi?blahblah&fjdksj or .php?stupid=qasic). If you give me the administrator rights to your board (UBB and FTP), I'll find the cause for you and fix up the problem.

qasic

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
quote:
You did not complete all required fields.
You did not complete: close_window

That problem occurs when your vars_wordlets_avatar.cgi is not up to date. Upload the one that's inside the ZIP file, modify your Avatar wordlets, save them and then all should be OK.

qasic

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
quote:
Originally posted by Ellen:
Has anyone figured out how to fix it so that we can upload through the control panel? I would appreciate any help possible here. Thanks.

Hi Ellen,

I've contacted you via e-mail so I can look into the problem. Please e-mail me back!

qasic

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Hi Morph,

I just checked your site and I was able to view that URL without any problems? Can you point me to another URL where it occurs? Thx.

qasic

Joined: Feb 2002
Posts: 51
I
Member
Offline
Member
I
Joined: Feb 2002
Posts: 51
quasic your hack is working perfectly on 6.2.1
only problem ( not that big as FTP is better wink )
is unable to upload using CP.
IF you fix that the hack could easily go to final !

Thank you

Inka

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Hi Inka,

I've already contacted Ellen to try to get her LOGIN info. If she doesn't respond, I ask another person for server details so I can crush this bug laugh

qasic

Joined: Apr 2001
Posts: 18
M
Junior Member
Offline
Junior Member
M
Joined: Apr 2001
Posts: 18
Hello Qasic,

I think I'll either have to clear the ubb cache, or you will have to clear your browser cache to be able to see the error again (The page referenced is one of the only pages with that error). I'll clear it now and if you could try it again that would be great.

Thanks,
Meta

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Morph, I just tried right now and I don't have any problems.

Secondly, that upload file problem is a confirmed problem for the UBB 6.2.x series on both UNIX and WINX computers. I'll be investigating solutions to this problem as soon as I have time.

qasic

Joined: Sep 2000
Posts: 159
E
Member
Offline
Member
E
Joined: Sep 2000
Posts: 159
I've sent you the info you requested. Anything for science...

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
New Version - 1.1

Download: http://www.qasic.net/main.cgi?action=details;file=avatar62

BugFixes:
  • fixed upload problem from cp (UBBCGI.pm)
  • optimized upload routine like upload example in CGI.pm documentation
  • additional security checks in ubb_avatar.cgi due to an inquiry via e-mail

Upgrade Instructions:
  1. Back up UBBCGI.pm (inside your UBB CGI / Modules directory), ubb_avatar.cgi and cp_avatar.cgi
  2. Re-hack UBBCGI.pm according to the instructions in the README.
  3. Replace ubb_avatar.cgi and cp_avatar.cgi with the files in this zip file.
  4. Upgrade complete.

qasic

Joined: Feb 2002
Posts: 51
I
Member
Offline
Member
I
Joined: Feb 2002
Posts: 51
Thank you quasic CP uploading is now working perfectly !

This hack should go in the finished mod page laugh

Inka

Joined: Apr 2001
Posts: 18
M
Junior Member
Offline
Junior Member
M
Joined: Apr 2001
Posts: 18
Hello Qasic,

I updated my scripts with your updates, although getting weird errors:

quote:
An error has occured:

d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi: Global symbol "$full" requires explicit package name at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 42.
Global symbol "$customavatarurl" requires explicit package name at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 43.
Missing right curly or square bracket at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 43, at end of line
syntax error at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 43, at EOF

Try it out... Here

Any suggestions?

Thanks,
Meta

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Inside ubb_avatar.cgi, try changing:

quote:

sub ValidateAvatar {
# $_[0] : URL to verify
unless( ($_[0] =~ m/^$vars_avatar{avurl}/)
||($_[0] =~ m/^$vars_avatar{cavurl}/)
||($_[0] eq '')) {
&PostHackDetails($vars_wordlets_avatar{avatar_hack});
}
} #end sub ValidateAvatar

to

quote:

sub ValidateAvatar {
# $_[0] : URL to verify
unless (($_[0] =~ m/^$vars_avatar{avurl}/) || ($_[0] =~ m/^$vars_avatar{cavurl}/) || ($_[0] eq '')) {
&PostHackDetails($vars_wordlets_avatar{avatar_hack});
}
} #end sub ValidateAvatar

LMK how that goes.

qasic

Joined: Apr 2001
Posts: 18
M
Junior Member
Offline
Junior Member
M
Joined: Apr 2001
Posts: 18
Eeek... This is What I get now:

quote:
d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi: Global symbol "$ext" requires explicit package name at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 147.
Global symbol "$customavatarurl" requires explicit package name at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 147.
Global symbol "$customavatarurl" requires explicit package name at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 147.
syntax error at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 149, near "$Custom = qq(

~ Meta

Joined: Apr 2001
Posts: 18
M
Junior Member
Offline
Junior Member
M
Joined: Apr 2001
Posts: 18
This one appears sometimes too:

quote:
d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi: Missing right curly or square bracket at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 191, at end of line
syntax error at d:/web/w126190/docs/ubbcgi/ubb_avatar.cgi line 191, at EOF


Joined: Apr 2001
Posts: 18
M
Junior Member
Offline
Junior Member
M
Joined: Apr 2001
Posts: 18
Hello Qasic,

Thanks for all your time on this... I think the problems could my version of Perl or Web server screwing things up (not sure though)... I'm noticing all kinds of these random errors with a bunch of the .cgi scripts (not just the avatar mod). Until I get the word from my web host about which version of Perl I have I think I'll have to roll with the punches for now, unless you have some suggestions.

Thanks,
~Meta

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
I just checked with another user who installed the avatar hack and he did not have the problem you are having.

I seriously suspect it's a problem with your host which probably has a faulty Perl installation. Sorry that I can't be of any help further frown

qasic

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
Hi folks,

Security Alert

There's an update for Avatar Hack that fixes a user being able to select any graphic on your website by using relative URLs. To fix this security problem, just replace your ubb_avatar.cgi with the one from this ZIP file.

Thanks for reading this.

qasic

Joined: Oct 2001
Posts: 213
L
Member
Offline
Member
L
Joined: Oct 2001
Posts: 213
I am not very good with Perl. Can someone tell me if this hack limits the size of the avatar - both in pixels and in physical (kb) size? I saw something about 35x80, but am totally unsure.

Thank you.

Joined: May 2001
Posts: 794
A
Content Queen
Offline
Content Queen
A
Joined: May 2001
Posts: 794
Qasic,

I am attempting to install this hack on my test board, and I have what appears to be an avatar_wordlets file in French (or German -- not sure the language! tipsy )*.

This is the name of the file I downloaded from --> Download Avatar Hack (UBB 6.2) 1.1 ...

Would I be able to use the avatar_wordlets from an earlier UBB (6.1.0.3) to replace the one I uploaded?

*OOOOOOOH! Is this new? I just added a graemlin, and instead of pasting it to the end of my message (like before), it went to where the cursor was. (Little things like this excite me!)


Sue
adwoff.com
Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
quote:
Originally posted by little_joe:
I am not very good with Perl. Can someone tell me if this hack limits the size of the avatar - both in pixels and in physical (kb) size? I saw something about 35x80, but am totally unsure.

Thank you.

Upload of a graphic via cp.cgi is limited to 100,000kb. The pixel limit may be set in the Avatar Settings in the Control Panel.

qasic

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
quote:
Originally posted by ADWOFF:
Qasic,

I am attempting to install this hack on my test board, and I have what appears to be an avatar_wordlets file in French (or German -- not sure the language! tipsy )*.

C'est francais. You may safetly use wordlets from the previous version with no problems.

qasic

Joined: Apr 2001
Posts: 12
E
Ed Offline
Junior Member
Offline
Junior Member
E
Joined: Apr 2001
Posts: 12
Hey there! I really need some help here!
I'm using "external_avatar_0.1" hack and it works great but please look at this:

http://www.die-happy.net/Bild1.jpg

Umm...I want to rezise all pictures to 64x64
How can I make this?

Thanks,
Ed

Joined: Mar 2002
Posts: 63
V
Member
Offline
Member
V
Joined: Mar 2002
Posts: 63
I tried to install avatar several time on my ubb version 6.2.0
It worked great, but...

When ppl edit their profiles, things like location, signature, occupation wont be saved ..

Anyone know why this happens?

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
quote:
Originally posted by Ed:
Hey there! I really need some help here!
I'm using "external_avatar_0.1" hack and it works great but please look at this:

http://www.die-happy.net/Bild1.jpg

Umm...I want to rezise all pictures to 64x64
How can I make this?

Thanks,
Ed

Wrong thread. Please ask in the correct one. Thanks.

qasic

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
quote:
Originally posted by VVouter:
I tried to install avatar several time on my ubb version 6.2.0
It worked great, but...

When ppl edit their profiles, things like location, signature, occupation wont be saved ..

Anyone know why this happens?

It's most likely that ubb_profile.cgi was not hacked correctly or public_register_form.pl wasn't either.

qasic

Joined: Apr 2001
Posts: 12
E
Ed Offline
Junior Member
Offline
Junior Member
E
Joined: Apr 2001
Posts: 12
Sorry qasic frown

But where is the thread? Please help frown

Ed

Joined: Apr 2001
Posts: 18
M
Junior Member
Offline
Junior Member
M
Joined: Apr 2001
Posts: 18
Qasic -

I just wanted to let you know that I switched versions of PERL (from ISAPI to .exe) and everything is working smoothly now. In fact I haven't seen an error since!

Thanks again for everything! I really appreciate it. laugh

~ Meta
Visive Parliament

Joined: Jan 2002
Posts: 63
D
Member
Offline
Member
D
Joined: Jan 2002
Posts: 63
hello when i installed this i got no error [but] in cp manage and for the upload part both screens are compleatly empty nothing no errors just a blank screen, and in member profiles a big chunk is gone.
any ideas as where i can look to solve this riddle.

Joined: Jan 2001
Posts: 1,940
Q
qasic Offline OP
Developer
OP Offline
Developer
Q
Joined: Jan 2001
Posts: 1,940
quote:
Originally posted by Metamorpheus:
Qasic -

I just wanted to let you know that I switched versions of PERL (from ISAPI to .exe) and everything is working smoothly now. In fact I haven't seen an error since!

Thanks again for everything! I really appreciate it. laugh

~ Meta
Visive Parliament

Yeah, ISAPI still has freaky bugs frown

qasic

Page 2 of 4 1 2 3 4

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Bill B
Bill B
Issaquah, WA
Posts: 87
Joined: December 2001
Forum Statistics
Forums63
Topics37,558
Posts293,857
Members13,848
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,819
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 70
Gizmo 16
Brett 7
WebGuy 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2022 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Snapshot build 20220120)
Responsive Width:

PHP: 7.3.29 Page Time: 0.046s Queries: 95 (0.025s) Memory: 1.0026 MB (Peak: 1.2054 MB) Data Comp: Zlib Server Time: 2022-01-27 06:28:18 UTC
Valid HTML 5 and Valid CSS