Previous Thread
Next Thread
Print Thread
Rate Thread
Page 1 of 2 1 2
Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Hack Name: Modification Wordlets for UBB 6.3.x

Description: A common set of Wordlet™ which many UBB™ hacks depend on.

Download: http://www.qasic.net/main.cgi?action=details;c=5;file=modword63

Please post any bug reports here.

qasic

Sponsored Links
Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
smile Good job

Edit:
[code][/code]Shouldn't it be cp_wordlets.cgi? tipsy

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
nope .. read inside cp_upgrade_data.cgi although I should add cp_wordlets.cgi to the list

qasic

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
ZIP file updated!

Joined: Dec 2000
Posts: 371
Member
Member
Offline
Joined: Dec 2000
Posts: 371
In cp.cgi and ultimatebb isn't it vars_wordlets_mods.cgi instead of vars_wordlet_mods.cgi ?

Sponsored Links
Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
Yes, it is

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Did I have an error somewhere?

qasic

Joined: May 2002
Posts: 28
Junior Member
Junior Member
Offline
Joined: May 2002
Posts: 28
Looked liked it worked for me but it didn't create the vars_wordlets_mods.cgi file when I upgraded the board. Any ideas? 6.3 beta 2

Thx

Joined: May 2001
Posts: 41
Member
Member
Offline
Joined: May 2001
Posts: 41
I got mine to show up in beta 1 but none of the other hacks work right now, when i try to install them. Like memberlist only one that worked was the CP addon.

Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
q/viper, [code][/code]Replace "wordlet_mods" with "wordlets_mods"

Sponsored Links
Joined: May 2001
Posts: 41
Member
Member
Offline
Joined: May 2001
Posts: 41
Thanks LK, also having a problem with ubb_lib for memberlist. I guess the other hacks will ported to 6.3b1 soon enough. smile

Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
Read the instructions again:[code][/code]Which means, open public_common.pl wink

Joined: May 2001
Posts: 41
Member
Member
Offline
Joined: May 2001
Posts: 41
I again thank you sir.

Must read directions i suppose laugh laugh wink

Joined: Sep 2000
Posts: 59
Member
Member
Offline
Joined: Sep 2000
Posts: 59
6.3's "cp_upgrade_data.cgi" is very different from 6.2 and has a lot of new code such as the code for avatars and Custom Graemlins. In other words the "cp_upgrade_data.cgi" file that comes with this hack is much smaller in file size than the stock 6.3 file. Is that intentional?

The problem I'm having is that when I try to select the "Modification Wordlet" in the CP, it changes to "Wordlet List" and all I see is "All fields are required!"

Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
Try to overwrite cp_upgrade_data.cgi with the hack's file, run "upgrade your ubb" and then put the old cp_upgrade_data.cgi back.

Joined: Sep 2000
Posts: 59
Member
Member
Offline
Joined: Sep 2000
Posts: 59
Well something is working because I also tried adding the CP add on hack and that appears to show in the CP. But for instance, I'm adding the spell check hack and the Spell Check button is not showing. See this url and the source looks like this:

[code][/code]where the value appears blank...

Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
You have to install both CP Mod Addon and Mod Wordlets. If you're sure that CP Mod Addon is insatlled correctly, enter CP - Modification Settings, choose to enable spellcheck, set a width/height and click on submit. Then install Mod Wordlets, hack vars_wordlets_mods.cgi and try again.

Joined: Sep 2000
Posts: 59
Member
Member
Offline
Joined: Sep 2000
Posts: 59
Well I have both of those as well as the Spell Check installed. You can view source of that page and see that. I can see the option in the pull down for "Modification Settings" and "Modification Wordlet List" but whenever I try to go to the latter it, i.e., the display results, changes back to "Wordlet Lists"...

Joined: Sep 2000
Posts: 59
Member
Member
Offline
Joined: Sep 2000
Posts: 59
Should "vars_wordlets_mods.cgi" look like this:

Code
[/code]also, the manual instructions for mods_wordlets_install.cgi says this:
[code]
So the only problem left is to figure out why the Spell Check button is not appearing properly...

Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
1. yes, it should be %vars_wordlets_mods.
2. Do you have ICQ, AIM, MSN Messenger?

Joined: Sep 2000
Posts: 59
Member
Member
Offline
Joined: Sep 2000
Posts: 59
answer to # 2: yes: AIM: Kudyba

also, I see that when I changed vars_wordlets_mods.cgi to look like the following it worked:

[code][/code]

Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
I have just wanted to tell you it's 'wordlet' instead of 'wordlets' wink Anyhow, you're offline? Please msg me @ LK UBB

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Silent update has occurred to fix the vars_wordlet_mods bug smile Thanks to LK!

qasic

Joined: Jun 2001
Posts: 2,849
Spotlight Winner
Spotlight Winner
Offline
Joined: Jun 2001
Posts: 2,849
ooops

Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
It should be wordlets_mods wink

Q, cp_upgrade_data.cgi - &WriteHashToFile($path, "vars_wordlet_mods", %vars_wordlets_mods);

Should be vars_wordlets_mods tipsy

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Fixed too smile

qasic

Joined: Nov 2001
Posts: 47
Member
Member
Offline
Joined: Nov 2001
Posts: 47
I just installed this mod and it messed up my BB good. It installed on my test forum ok but on my main BB something went very wrong. I've tried to restore the original files but it's still a no go. From what I can tell it is setting the file permissions to the adminlog.cgi and vars_misc.cgi to 0 when I set them back they get reset back to 0 again.
When I try to do anything in the CP I get this error
quote:
An error has occured:

Can't open '/home/httpd/vhosts/needforbetterspeed.net/httpdocs/forum/ubb/BanLists/adminlog.cgi'.

Permission was denied - please ask the administrator to check the permissions on that file/directory!

The exact error returned by the operating system is:
Permission denied

When I look at that file the CHMOD is at 0 when I change it and try to say rebuild the forum stat files I get this error
quote:
Can't open '/home/httpd/vhosts/needforbetterspeed.net/cgi-bin/forum/vars_misc.cgi'.

Permission was denied - please ask the administrator to check the permissions on that file/directory!

The exact error returned by the operating system is:
Permission denied

Then when I fix that one the adminlog goes back to 0 I'm stuck bigtime
When you try to go to my forum this is the error that comes up
quote:
Software error:
LoadStyleTemplate no longer takes a number.Backtrace: ultimatebb.cgi:157 -> sub main::LoadStyleTemplate
Backtrace: ubb_lib.cgi:1836 -> sub main::Tracer

Help please frown

Joined: Nov 2001
Posts: 47
Member
Member
Offline
Joined: Nov 2001
Posts: 47
Now the forum is back to 6.2.1.1 confused it was 6.3.0 when I started confused

edit I had to re-upgrade the BB to 6.3.0 still confused lol

Joined: Jun 2001
Posts: 572
Member
Member
Offline
Joined: Jun 2001
Posts: 572
Action not permitted.

» Use your browser's back button to return.

That's what I get when I go to CP >> Wordlets >> Modification Wordlets.

~Jon

Joined: Mar 2002
Posts: 21
Junior Member
Junior Member
Offline
Joined: Mar 2002
Posts: 21
Hi

Using 6.3 Final

I have had lots of trouble installing the mods file on 6.2 and 6.3........lol

BUT Yippe I have now got it done-- how ???

Well, I hope it is anyway it is the furthest I have gotten.

Before I install some hacks I would like someone to look at my "vars_wordlets_mods.cgi" file and tell me if it is OK, I do not know what this line is?

q!HASH(0x85dfbb8)! => undef,

should it be there?

%vars_wordlets_mods = (
q!mod_wordlets! => q!Modification Wordlets!,
q!HASH(0x85dfbb8)! => undef,
);

1;

CP - Modification Wordlets screen shot

[Linked Image]

Anything else I should check.

Joined: Nov 2001
Posts: 47
Member
Member
Offline
Joined: Nov 2001
Posts: 47
quote:
Originally posted by JonNJapan:
Action not permitted.

» Use your browser's back button to return.

That's what I get when I go to CP >> Wordlets >> Modification Wordlets.

~Jon

Thats what I'm getting now too

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Did not hack cp_wordlets.cgi and cp.cgi?

qasic

Joined: Nov 2001
Posts: 47
Member
Member
Offline
Joined: Nov 2001
Posts: 47
I just doubled checked cp.cgi and cp_wordlets.cgi and I did hack them confused

Joined: Jun 2001
Posts: 572
Member
Member
Offline
Joined: Jun 2001
Posts: 572
quote:
Originally posted by Acadian:
I just doubled checked cp.cgi and cp_wordlets.cgi and I did hack them confused

Ditto.

~Jon

Joined: Mar 2002
Posts: 21
Junior Member
Junior Member
Offline
Joined: Mar 2002
Posts: 21
Hi

I take it as no-one has answered my last post that no-one knows what this line below is in the vars_wordlets_mods.cgi file?

q!HASH(0x85dfbb8)! => undef,

should it be there?

The vars_wordlets_mods.cgi file looks like this
===============================================

%vars_wordlets_mods = (
q!mod_wordlets! => q!Modification Wordlets!,
q!HASH(0x85dfbb8)! => undef,
);

1;

See screen shot on previous page

confused

Joined: Feb 2001
Posts: 2,285
Old Hand
Old Hand
Joined: Feb 2001
Posts: 2,285
I had trouble with my wordlets not showing after I added this new version. I replaced the new vars_wordlets_mods.cgi with one I had from a previous install and viola! It worked.

This is what I've discovered. The newly created vars_wordlets_mods.cgi looks like this:

Code
[/code]The old one looks like this:

[code]
Soooo, what gives? Is the new vars_wordlets_mods.cgi not being created properly?

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Hi folks,

Sorry for the delay in getting the fix to the HASH problem for you. For the people who already have the HASH value, just remove the line, save your vars_wordlets_mods.cgi, and upload. That's all.

For any other folks, the ZIP file has been silently updated to cover this bug. The only file that has changed is cp_upgrade_data.cgi.

qasic

Joined: Nov 2001
Posts: 159
Member
Member
Offline
Joined: Nov 2001
Posts: 159
nm

Joined: Jan 2001
Posts: 1,940
Developer
Developer
Offline
Joined: Jan 2001
Posts: 1,940
Good ... another bug squashed by a user smile

qasic

Joined: Jul 2000
Posts: 837
Member
Member
Offline
Joined: Jul 2000
Posts: 837
ok never mind i got it working now

Page 1 of 2 1 2

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Bill B
Bill B
Issaquah, WA
Posts: 87
Joined: December 2001
Forum Statistics
Forums63
Topics37,574
Posts293,926
Members13,850
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,833
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 82
Gizmo 20
Brett 7
WebGuy 2
Morgan 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2024 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Preview build 20240506)