Previous Thread
Next Thread
Print Thread
Rate Thread
Page 3 of 4 1 2 3 4
Joined: Mar 2002
Posts: 10
P
Junior Member
Offline
Junior Member
P
Joined: Mar 2002
Posts: 10
Thanks freak (and LK, for the hack). It's working perfectly now!

Sponsored Links
Joined: Aug 2001
Posts: 41
I
Member
Offline
Member
I
Joined: Aug 2001
Posts: 41
Well when i was installing the script, I added the lines:

#UBB 6.3.0.1
# Open ultimatebb.cgi (In Cgi-Bin)

Quote
code:
Code
 if ($ubb eq 'memberlist') {
&RequireCode("$vars_config{CGIPath}/ubb_memberlist.cgi");
&memberlist_parse; exit(0);
} #end memberlist

like it install file called for. everything went with out a hitch than it came time to view the memberlist to make sure it worked correctly. sad to say it did not, it would load the members page but not list any of the members that I have set up as a demo to test on my computer.

So I've went over the install files, reintalled it, and even reinstalled the whole ubb thinking it was a conflict with another hack i install previously to the members list.

Than the morning after, I'm looking at the file and you see the code listed above..

code:
[qb]
Code
if ($ubb eq 'memberlist') {
&RequireCode("$vars_config{CGIPath}/ubb_memberlist.cgi");
&memberlist_parse; exit(0);
} #end memberlist
[/qb]
well im no perl expert, only the basics and some other misc features to get me by. i just simply moved the:

Quote
code:
Code
exit(0);

to a new line saved the template and it worked just fine. thats why i felt so dumb, because i didnt catch it the first time around.

so it came out like this:

code:
[qb]
Code
if ($ubb eq 'memberlist') {
&RequireCode("$vars_config{CGIPath}/ubb_memberlist.cgi");
&memberlist_parse;
exit(0);

} #end memberlist
[/qb]
and it worked laugh
simple yet it just puzzled me tipsy

Joined: May 2002
Posts: 28
N
Junior Member
Offline
Junior Member
N
Joined: May 2002
Posts: 28
so is this 6.3.1 then? its a lil unclear?

Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
Codec, there is no difference. tipsy It's just a coincidence.

Not Great and stuff, I'm gonna port my hacks to work with 6.3.1 in a bit.

Edit: Codec, btw, please make your signature image max 150x50.

Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
Documention updated for 6.3.1 smile

Sponsored Links
Joined: Jan 2001
Posts: 8
B
Junior Member
Offline
Junior Member
B
Joined: Jan 2001
Posts: 8
Hi LK,

Everything seems to work fine... only I am missing the stats titles! All the stats show up but no titles to the left of them!! Uhhh... can you point me in the right direction!

Thanks,

-BusBoy-


~~BusBoy~~
Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
URL? (if it's 6.1.0.3, upgrade)

Joined: May 2001
Posts: 6,708
L
Member
Offline
Member
L
Joined: May 2001
Posts: 6,708
Quote
quote:
Originally posted by LK:
Documention updated for 6.3.1 smile
Anything need to be changed if I did a port upgrade to 6.3.1 and it's working fine there?

Joined: Feb 2000
Posts: 4,625
G
Member
Offline
Member
G
Joined: Feb 2000
Posts: 4,625
After a quick glance....i doubt it.

Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
LD, it uses Wordlets for CP, so rehack cp_common.pl and cp_lib.cgi

Sponsored Links
Joined: Aug 2001
Posts: 41
I
Member
Offline
Member
I
Joined: Aug 2001
Posts: 41
ok, just telling you the problem i ran into. I'll make the sig smaller lk.

Joined: May 2001
Posts: 58
C
Member
Offline
Member
C
Joined: May 2001
Posts: 58
I have a issue with Membership in 6.3.1. I installed it and it maxes my CPU and 5x's my memory usage. It also does not allow the recent visitors log to reset. I am not able to pin it down, and had to revert to backup files. Perl.exe (Win2k) was 16mb or larger...

Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
Memberlist can't work well with big sites, because it has to sort everything by the way you choose... I suggest you to uninstall it. frown

About recent visitors log - impossible, cause it doesn't touch those files... It's probably a side effect of server's CPU usage...

Joined: Apr 2001
Posts: 31
D
Junior Member
Offline
Junior Member
D
Joined: Apr 2001
Posts: 31
LK, how big is to big for the memberlist? I have a site with about 3100 (and slowly growing) registerd members. I also cannot afford a large impact on CPU usage. Would memberlist work okay on a site like this or would it be to much?

Thanks,
Adam

Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
Just try it, if it loads very quickly it's fine tipsy

Joined: Mar 2001
Posts: 326
M
Member
Offline
Member
M
Joined: Mar 2001
Posts: 326
You should be ok, although I'd say that you're also close to the breaking point of being good or not for use. At around 4,000 members it starts to get tedious.

On our forum with 6.1K it takes 3 - 4 minutes, thus it's removed in our next upgrade.

Joined: Mar 2001
Posts: 326
M
Member
Offline
Member
M
Joined: Mar 2001
Posts: 326
Ok you'll say NO, but I'll suggest it anyway.

Why not do a special versions for larger forums, which via a CP interface, allows you to build a special file for members once and have that access via the forum.

Ok you'd need to build it to include new members (wouldn't have to, new ones never really matter =]), yet it'd make things a lot faster. Dealing with thousands of files dynamically is obviouslly less appealing =).

Joined: Dec 2001
Posts: 37
D
Junior Member
Offline
Junior Member
D
Joined: Dec 2001
Posts: 37
Installed it on 6.3.1 with JCTemplates looks really nice actually! But I have an idea for my site, if this is possible. Id like to make a time slip database that lists, fastest to slowest with a email link or PM link, very similar to the member list. THe option I have for a persons e/t run is already implimented, and if I do a sort by e/t, it already lists from fastest to slowest. So I know its possible, just a matter of stripping the file just not sure where to start. Possible?

Joined: May 2001
Posts: 58
C
Member
Offline
Member
C
Joined: May 2001
Posts: 58
Quote
quote:
Originally posted by DigiMaster:
Installed it on 6.3.1 with JCTemplates looks really nice actually! But I have an idea for my site, if this is possible. Id like to make a time slip database that lists, fastest to slowest with a email link or PM link, very similar to the member list. THe option I have for a persons e/t run is already implimented, and if I do a sort by e/t, it already lists from fastest to slowest. So I know its possible, just a matter of stripping the file just not sure where to start. Possible?
Time slip for drag racing? What server are you running? We have developed a timeslip database running in ASP that is seperate from the ubb, but looks at the ubb cookie and members folder to verify membership. It even has an upload picture capability. We are considering marketing it, let me know if interested.

Joined: Dec 2001
Posts: 37
D
Junior Member
Offline
Junior Member
D
Joined: Dec 2001
Posts: 37
yea its for a F-Body website. Im working on one for a phpBB with a friend, its completed but its buggy. Nice feature aint it? Unfortunatly, its unix system, frown so asp wont work

Joined: May 2001
Posts: 180
D
Member
Offline
Member
D
Joined: May 2001
Posts: 180
Hi,

I have a problem with my memberlist - I think I hacked it right, I checked it several times, but I just get a blank page :

http://www.forumdeluxx.com/ubb/ultimatebb.php?ubb=memberlist

Is it possible that the server load is very high so that it cuts off the calculating after a certain period ? My hoster is doing something like that, the old UBBs had long threads and showed a blank page as well...

Is there a workaround for that ?

Best regards,
Dennis


Regards Dennis Bode
-----------------------------
Webmaster of Hardwareluxx.com
Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
hmm, memberlist is in ultimatebb.CGI, not php :rolleyes: wink

Joined: May 2001
Posts: 180
D
Member
Offline
Member
D
Joined: May 2001
Posts: 180
oh...

... hmm laugh

You´re right *g*


Regards Dennis Bode
-----------------------------
Webmaster of Hardwareluxx.com
Joined: May 2001
Posts: 180
D
Member
Offline
Member
D
Joined: May 2001
Posts: 180
Ok, now it works, but I get a

Undefined subroutine &main::AlternateColors called at /homepages/45/d32051836/htdocs/ubb/Templates/cp_vars_memberlist.pl line 10.

in the CP when I chose "Memberlist"...

And there are some blank entries in the search by-option on the memberlist page in the forum...


Regards Dennis Bode
-----------------------------
Webmaster of Hardwareluxx.com
Joined: Jun 2001
Posts: 26
C
Junior Member
Offline
Junior Member
C
Joined: Jun 2001
Posts: 26
I'm getting the same thing here!

"Undefined subroutine &main::AlternateColors called at /homepages/45/d32051836/htdocs/ubb/Templates/cp_vars_memberlist.pl line 10."

Joined: Dec 2000
Posts: 78
E
Ed Offline
Member
Offline
Member
E
Joined: Dec 2000
Posts: 78
I have just installed memberlist and it appears to be working OK.
Although when I click on "Merberlist Settings" in the control panel I get this response - "You do not have permission to access this area"

Anyone any ideas?

I am using 6.30

Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
Rehack cp.cgi...
dbode, Crow, Ed, you're using 6.3.0 (not .1), so remove all instances of "&AlternateColors;" in cp_vars_memberlist.pl.

Joined: May 2002
Posts: 4
S
Junior Member
Offline
Junior Member
S
Joined: May 2002
Posts: 4
I'm having a similar problem myself. Everything installs fine, memberlist works in the forums itself, but i can't adjust anything in the cp, it just loads upto the section that says Column display options, then the rest of the box is just thick blue. Any ideas?

UPDATE: Have just rehacked cp.cgi and all other cp related files used, and checked all permissions. Everything is set properly, it just isnt loading the memberlist file within the cp frown

Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
Re-upload cp_vars_memberlist.pl tipsy

Joined: May 2002
Posts: 4
S
Junior Member
Offline
Junior Member
S
Joined: May 2002
Posts: 4
ok, i did that, reset the permissions to 755 as the zip says and it still has the same screen frown

UPDATE:
I might have got it, just trying the advice that you gave the peeps above me about deleting the &AlternateColors bit on a 6.3.0

Joined: May 2002
Posts: 4
S
Junior Member
Offline
Junior Member
S
Joined: May 2002
Posts: 4
Sweet, that worked when i reuploaded the edited one laugh thanks dude thumbsup

Joined: Dec 2000
Posts: 78
E
Ed Offline
Member
Offline
Member
E
Joined: Dec 2000
Posts: 78
Thanks LK - the &AlternateColors; removal corrected the problem.

Joined: Mar 2000
Posts: 63
S
Member
Offline
Member
S
Joined: Mar 2000
Posts: 63
Hi there, I've installed this on 6.3.1, but when I go to the forums main page there's no link to the memberlist and when I type in the url directly I get the error message:

Code
Undefined subroutine &main::set_page_elements called at E:alumnicgi-binubb_memberlist.cgi line 13.
I can access the memberlist settings in the cp okay though.

Anyone able to help please?

Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
hmm, if you don't have Mod Wordlets just install it.

Joined: Sep 2002
Posts: 16
B
Junior Member
Offline
Junior Member
B
Joined: Sep 2002
Posts: 16
Very nice - Working fine laugh

Joined: Oct 2002
Posts: 1
W
Junior Member
Offline
Junior Member
W
Joined: Oct 2002
Posts: 1
thx gonna check it out

Joined: May 2002
Posts: 48
W
WC Offline
Member
Offline
Member
W
Joined: May 2002
Posts: 48
There a way to get this working with 6.20 ?
Followed the instructions in the zip file, hacked ubb_lib.cgi and it still shows up as a blank page when going to the member list

[EDIT] NM Got it to work using the 6.4.3 version of the files

Joined: Feb 2001
Posts: 55
A
Member
Offline
Member
A
Joined: Feb 2001
Posts: 55
Is there some way to change the font to the same one on the rest of the given board? I like the hack, but Times, new roman is killin' me!

Joined: Oct 2002
Posts: 16
S
Junior Member
Offline
Junior Member
S
Joined: Oct 2002
Posts: 16
any URL to download this hack?
thanks.

Joined: Mar 2001
Posts: 7,394
L
LK Offline OP
Admin / Code Breaker
OP Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
stefans, if you mean this hack, Memberlist 6.4.5:
Quote
quote:
Originally posted by LK:
[QB]Download: ZIP File or MultiHack File
If you mean the 6.2 version, it's in 6.0-6.2 mods forum tipsy

Arms, it should use the same font face, where doesn't it? confused

Page 3 of 4 1 2 3 4

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Bill B
Bill B
Issaquah, WA
Posts: 87
Joined: December 2001
Forum Statistics
Forums63
Topics37,558
Posts293,857
Members13,848
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,819
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 70
Gizmo 16
Brett 7
WebGuy 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2022 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Snapshot build 20220120)
Responsive Width:

PHP: 7.3.29 Page Time: 0.063s Queries: 95 (0.037s) Memory: 0.9926 MB (Peak: 1.1870 MB) Data Comp: Zlib Server Time: 2022-01-27 06:17:02 UTC
Valid HTML 5 and Valid CSS