Previous Thread
Next Thread
Print Thread
Rate Thread
#323687 02/11/2023 8:13 AM
Joined: Aug 2014
Posts: 14
Likes: 2
Newbie
Newbie
Joined: Aug 2014
Posts: 14
Likes: 2
Who came first the egg or the hen...

Our current forum version is 7.7.5

From my host I keep getting error messages with my very old current VPS solution,
and my host recommend a migration and say

Quote
Your system is running centos7, and while not yet end of life a future migration to almalinux8 + cpanel should be considered. We would migrate everything to the new set up.

What do you tech guys recommend?
Should I await and first install version 8 when it is available or is it considered secure just to migrate to almalinux8 with 7.7.5?
at this moment we use
PHP Version: 5.6.40
MySQL Version: 5.7.41
cURL Version: 7.87.0

I hope this is not off topic

Thanks for your advise

Last edited by Morgan; 02/11/2023 8:14 AM.
Sponsored Links
Morgan #323688 02/18/2023 8:36 PM
Joined: Jan 2000
Posts: 5,833
Likes: 20
UBBDev / UBBWiki Owner
Time Lord
UBBDev / UBBWiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,833
Likes: 20
There is no current timetable for UBB.threads v8. Your current UBB.threads version will work fine on PHP7.

As mentioned on your thread at UBBCentral:

In development we're testing against MariaDB v10.4.27 but it should work just fine on the latest MariaDB LTS (currently 10.6, all of this is equivalent to MySQL8). We do not test against release candidates or alpha/beta releases.

You will want to run on the latest PHP7 build available to you until UBB.threads v8 is released. The newer the build the faster PHP scripts will process.


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, My UBB Scripts
Morgan #323689 02/19/2023 2:42 AM
Joined: Aug 2014
Posts: 14
Likes: 2
Newbie
Newbie
Joined: Aug 2014
Posts: 14
Likes: 2
Thanks for your reply Giz,
I believe my steps are
1, upgrade PHP5 to PHP7
2a, upgrade MySQL Version: 5.7.41 to ??? or
2b, migrate to MariaDB version ???
3 Upgrade to UBBT8 when available
4 migrate to almalinux8 or what my host recommendation is.

Step 1 is to contact helpdesk and ask for a backup and change to PHP7. I don't want to do these things my self.
I'll do it in a couple days.

Do you have any recommendations regarding the procedure?
Thanks

Morgan #323690 02/20/2023 1:42 AM
Joined: Jan 2000
Posts: 5,833
Likes: 20
UBBDev / UBBWiki Owner
Time Lord
UBBDev / UBBWiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,833
Likes: 20
As long as almalinux8 has PHP7 available then it should be safe to migrate to it; UBB.threads v7.7.x should run on newer PHP7 builds without issue.

IIRC almalinux is a derivative of CentOS/RHEL.


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, My UBB Scripts

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Gizmo
Gizmo
Portland, OR, USA
Posts: 5,833
Joined: January 2000
Forum Statistics
Forums63
Topics37,573
Posts293,925
Members13,849
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,833
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 82
Gizmo 20
Brett 7
WebGuy 2
Morgan 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2024 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Preview build 20221218)