Previous Thread
Next Thread
Print Thread
Rate Thread
#93358 03/04/2006 12:46 AM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
I was backing up my DB by means of WSFTP LE, as normal.

Somehow, I managed to dork things up. I'm now getting a "Premature end of script headers" for cp.cgi and ultimatebb.cgi.

Willing to pay for prompt help because of time constraints, and we are a non-profit 503(c) organization planning a fund raiser. I know, great timing huh.

The site is:

www.tinbenders.org/cgi-bin/ultimatebb.cgi

and I had issues from a problem before where I ended up with 2 cgi-bin folders, one for members and the other for the actual CGI's. I have all the paths and an FTP login handy.

Please email with offer of help.

[email protected]

Thank you.

Sponsored Links
#93359 03/04/2006 8:10 AM
Joined: Jan 2003
Posts: 3,456
Likes: 2
I
Master Hacker
Offline
Master Hacker
I
Joined: Jan 2003
Posts: 3,456
Likes: 2
you've been emailed

#93360 03/04/2006 2:35 PM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
And I replied again wink

Thanks!

#93361 03/04/2006 10:14 PM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
Ian,
My Hero, have you left me? wink

#93362 03/05/2006 12:25 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
I
Master Hacker
Offline
Master Hacker
I
Joined: Jan 2003
Posts: 3,456
Likes: 2
every ftp software I've used has defaulted .cgi to binary, so you should check that. You should really just reset vars_config to reflect the old path, since that path worked.

Sponsored Links
#93363 03/05/2006 7:35 PM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
I would, and I'll check the file, but I didn't actually get that far. I didn't *edit* any files, I mearly FTP'd to my HDD and when it broke, I copied the member folder over.

Thanks!

#93364 03/05/2006 7:37 PM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
I just checked the vars_config and this is what it is set to:

%vars_config = (
q!AdminLogging! => q!YES!,
q!BBName! => q!TinBenders.Org 4x4!,
q!CGIPath! => q!/home/httpd/vhosts/tinbenders.org/cgi-bin!,
q!CGIURL! => q!http://www.tinbenders.org/cgi-bin!,
q!CachePath! => q!/home/httpd/vhosts/tinbenders.org/httpdocs/Forums/ubb//cache-[REMOVED]!,
q!Cookie_Number! => q!2453215.1718!,
q!EnableAccel! => q!NO!,
q!MaxMemFields! => q!71!,
q!MembersPath! => q!/home/httpd/vhosts/tinbenders.org/cgi-bin/Members!,
q!NonCGIPath! => q!/home/httpd/vhosts/tinbenders.org/httpdocs/Forums/ubb/!,
q!NonCGIURL! => q!http://www.tinbenders.org/Forums/ubb!,
q!VariablesPath! => q!/home/httpd/vhosts/tinbenders.org/cgi-bin!,
q!cache_pw! => q![REMOVED]!,
);


1;

#93365 03/05/2006 7:43 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
you've got 2 / in the cache path right after ubb

Forums/ubb//etc

May or may not be the problem.

you've also got a / at the end of your NonCGIPath, you might want to remove that - that's actually what's adding the extra / in your cache path.


- Allen wavey
- What Drives You?
#93366 03/05/2006 9:58 PM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
Changes Made. Thank you Allen! I wish I could say that fixed it, but it didn't.

Since I had FTP on auto for the file transfers, both ways... Is there any way that I can fix a Binary transfer, asuming that was the problem?

I'm still getting:

The server encountered an internal error and was unable to complete your request.
Error message:
Premature end of script headers: ultimatebb.cgi
If you think this is a server error, please contact the webmaster

#93367 03/05/2006 11:14 PM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
What encoding should the file be?

Within Plesk, I can change the encoding by means of a drop-down menu. Ut was set to UTF-8, I changed it to ASCII, but no joy.

Sponsored Links
#93368 03/05/2006 11:16 PM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
I just checked ultimatebb.cgi, it was already set to ascii.

#93369 03/05/2006 11:42 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
have you made extensive modifications to your files? You could always upload fresh ones until you figure out the issue


- Allen wavey
- What Drives You?
#93370 03/05/2006 11:44 PM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
I've got a few hacks installed, Quick reply, calender etc.

I would easily give them up, if I thought I could upload some non-modified files and make them work, but I'm not sure what I would need to upload, and whether or not it would work with the user profile cgi's that have extra fields. My concern would be a "hack attempt" error.

#93371 03/05/2006 11:45 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
I
Master Hacker
Offline
Master Hacker
I
Joined: Jan 2003
Posts: 3,456
Likes: 2
Don't worry about that, you'll only need to update one line of ubb_lib.cgi for that.

#93372 03/05/2006 11:48 PM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
So where would I start? Should I just backup (again frown ) the CGI folder, and replace the cgi files in it? Excluding the subfolders ofcourse?

#93373 03/05/2006 11:55 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
pm me ftp access and I'll fix it for you.


- Allen wavey
- What Drives You?
#93374 03/06/2006 9:38 AM
Joined: Nov 2003
Posts: 156
P
Member
OP Offline
Member
P
Joined: Nov 2003
Posts: 156
PM'd wink

#93375 03/07/2006 12:36 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Looks like it works again, was it a server issue?


- Allen wavey
- What Drives You?

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
badfrog
badfrog
somewhere on the coast of Maine
Posts: 94
Joined: March 2007
Forum Statistics
Forums63
Topics37,557
Posts293,856
Members13,847
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,819
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 70
Gizmo 16
Brett 7
WebGuy 2
Morgan 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2021 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Snapshot build 20210915)
Responsive Width:

PHP: 7.3.29 Page Time: 0.024s Queries: 50 (0.013s) Memory: 0.8693 MB (Peak: 0.9582 MB) Data Comp: Zlib Server Time: 2021-12-02 09:38:11 UTC
Valid HTML 5 and Valid CSS