Previous Thread
Next Thread
Print Thread
Rate Thread
Page 1 of 6 1 2 3 4 5 6
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Name: Thread-Integrated UBB™ Polls

Description: This is a thread-integrated ubb poll script that allows your members to start polls with new threads and have other members vote on the poll. There is also the ability for them to leave coments in the thread when they vote.

Original Author: Ryan Olson

Demo: https://ubbdev.com

Link: http://beta.collegevilletc.com/thread-polls.zip

(Updated 06/02/2001)

Requires: DPK's Wordlet Dev Kit to be installed first.


- Allen wavey
- What Drives You?
Sponsored Links
Joined: May 2001
Posts: 2,798
Member
Member
Offline
Joined: May 2001
Posts: 2,798
Gonna go install *Runs Away* Looks Good

Joined: May 2001
Posts: 2,798
Member
Member
Offline
Joined: May 2001
Posts: 2,798
I have two requests:

  • The option/ability to have UBBPolls only work in certain forum. Anotherwards an option when you edit a forum or create one is to have the ability to turn it on or off for that thrad.
  • It would be totally kewl if it also had an option that would like rate something.. Option to turn off for certain forums and such. And when posting the Poll you have a choice to add an image and get it rated.. I know it could be done but it would look so much betta as a Poll kind of thing..



Thanks very much for listening to my ideas.

Joined: Apr 2001
Posts: 711
Spotlight Winner
Spotlight Winner
Offline
Joined: Apr 2001
Posts: 711
Very nice and useful hack. smile Thanks a bunch. wink

[ May 31, 2001 11:50 PM: Message edited by: Zach B ]

Joined: May 2001
Posts: 52
Member
Member
Offline
Joined: May 2001
Posts: 52
If I'm not mistaken you have HTML or UBB Code Enabled for you forums. If you want to rate a photo, create a poll then in the message body rate this image: [ImageCode]

Adding restrictions to which forums have the polls enabled is possible, but it will require a bit more overhead. I'll put it on the TODO list.

Another possibility would be to have the title of the poll be different than the title of the topic. If that was an editable option, you could put your image as the title. That way the image becomes part of the poll table. That is an interesting possibility!

Sponsored Links
Joined: May 2001
Posts: 2,798
Member
Member
Offline
Joined: May 2001
Posts: 2,798
I am diggin' it it sounds good!

Thanks for listening to my requests.

[ June 01, 2001 10:31 AM: Message edited by: Tech-Ni-Kal ]

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Hey Ryan, just a note to say that the poll Melder started here and I moved to chit chat never showed up in chit chat, even after refreshing the screen a couple of times. smile

edit: nevermind, it showed up after someone else posted in that forum in another thread... leetle bug then smile


- Allen wavey
- What Drives You?
Joined: Apr 2001
Posts: 711
Spotlight Winner
Spotlight Winner
Offline
Joined: Apr 2001
Posts: 711
Ok, I'm having a couple problems with this:

  • The 'new poll' image won't show up. I have named it the right file name in the Style Templates and it still will no work. Instead the Style Templates does not save it and it stays blank everytime.

    Next, everytime someone votes or replies, it gets double posted.


Anybody else having these problems and does anyone know how to fix?

Joined: May 2001
Posts: 52
Member
Member
Offline
Joined: May 2001
Posts: 52
You know that actually happened to me. Allen do you know why this is?

I just went in and put the entry in the for the poll image (which is BBPoll) in the style files. That is a temporary fix.

Is it double voting or double posting. If it is double posting you added a particular block rather than replacing it. In looking at the install directions you probably errored in the second to last step of the ubb_new_reply.cgi section.

Definitely check to make sure you did everything right in the ubb_new_reply.cgi, that is where you error is coming from.

[ June 01, 2001 02:15 AM: Message edited by: Olson ]

Joined: Apr 2001
Posts: 711
Spotlight Winner
Spotlight Winner
Offline
Joined: Apr 2001
Posts: 711
I'll go check that now, but I just found out it has doubled every post on the whole message board! Hopefully, I can fix it. smile

Sponsored Links
Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
Bugs:


    [*](the only real bug) Sometimes it's "Voting With No Comment" and sometimes it's "VotingWithNoComment". I changed everything to "Voting With No Comment" and it worked.

    [*]In ubb_forum.cgi, $vars_style{BBTopic} is duplicated (instead of once {BBTopic} and once {BBPoll}), and it uses $vars_wordlets{post_new_topic}.

    [*]In ubb_lib.cgi, the icon has $vars_wordlets{post_new_poll}, which doesn't exist.

    [*]the name and everything is centered (it's just a little
    in public_poll_page.pl).

    [*]There is no title unless I use the custom title hack (it can be fixed by a little else)

    [*]Its width isn't correct, so the text/poll doesn't start like the replies do (change width="90%" to width="100%" in public_poll_page.pl)

    [*]The Registered: in the bottom doesn't have the registered information. (the most simple solution is BEFORE "# author info options", add $RegDateVote = $RegDate;, and then in ubb_poll_ssi.cgi, call $RegDateVote instead of $RegDate)


Example of the last 4 ones: https://www.ubbdev.com/ubbcgi/ultimatebb.cgi?ubb=get_topic&f=10&t=000932

MasterMind is aligned to the center, there is no "Moderator" under him, "Registered:" has no text afterwards, and "Posts: 3225" (in the same line) isn't exactly above freakscene's icon.

[ June 01, 2001 06:06 AM: Message edited by: LK ]

Joined: Sep 2000
Posts: 20
Junior Member
Junior Member
Offline
Joined: Sep 2000
Posts: 20
I had the same problem, fixed it by adding BBPoll at the end of the line that starts

Code
code:

cp_styles.cgi and not after BBTopic

Dont ask why but it worked for me that way and not the other way.

One problem I do have is when I create a new style template there is no option to add the graphic, when i try and submit I get told I cant leave that field blank, I may of missed a bit of code so will double check when I get home smile

[ June 01, 2001 09:22 AM: Message edited by: Marty ]

Joined: Mar 2001
Posts: 7,394
LK Offline
Admin / Code Breaker
Admin / Code Breaker
Offline
Joined: Mar 2001
Posts: 7,394
Marty, here I did something I forgot what to fix it, and it's not that...

About the other thing, do the same to cp_add_new_template.pl as to cp_vars_styles.pl

Joined: Jan 2001
Posts: 72
Member
Member
Offline
Joined: Jan 2001
Posts: 72
I dig the comments feature. Very spiffy. smile

What I dont like is the Item #1 || Item #2 || Item #3....and so on. Would it be possible to create "X" amount of input boxes (X being how many poll options users are alowed to make).

The input boxes would be alot easier for newBs, as some [stupid] people get dumb and cant use the "||"s.

BTW, if im not mistaken, the thread integrated polls use "3d" table borders. Could you make it so the poll has borders that you set in the CP?

Also, letting the inside of the poll box (in a thread) be the opposite alternating table color??

Hope you understand what I was getting at, and thanks for listening to my ideas.

Joined: Oct 2000
Posts: 807
Member
Member
Offline
Joined: Oct 2000
Posts: 807
had it insdtalled for bout a week now workin perfect......
http://www.411hype.com/cgi-bin/ubb/ultimatebb.cgi?ubb=get_topic&f=12&t=000546

Joined: Dec 2000
Posts: 62
Member
Member
Offline
Joined: Dec 2000
Posts: 62
Just instaled it on my ubb6.04e(private)board,and everything seems to work with c.p and all but when doing a test poll the actuall poll don't show up in the post!?

Tryed to cmod the public_poll_page.pl to 755 and 777 but still no luck,and i have looked at my code but can't se any errors in my code hacking.

Anyone know what could be wrong here?

Joined: Aug 2000
Posts: 874
Moderator / Developer
Moderator / Developer
Offline
Joined: Aug 2000
Posts: 874
Quote
quote:
are you clearing the page cache after you move the topic and after the poll gets added to the thread?

Joined: May 2001
Posts: 52
Member
Member
Offline
Joined: May 2001
Posts: 52
Nice Work LK,

The format issues (width, centering, and registration date) were all left-overs from the format on my board.

I fixed all other bugs. I'll update the zip files as soon as I learn how to from allen!!

I'm not sure the "Vote With No Comment" and the "VoteWithNoComment" is really a bug, because I have those on my board and the poll works fine. However, for consistency, I'll change them!

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
You can either email them to me at info@ubbdev.com , or send me a link to them, or, if you think you'll be updating them often, I can link the first post to a copy you have...:)


- Allen wavey
- What Drives You?
Joined: Jun 2000
Posts: 150
Member
Member
Offline
Joined: Jun 2000
Posts: 150
i also installed, and have checked all my files over, and i get to "Post Topic" buttons on my pages and no "New Poll" buttons

in the style settings in the CP the correct icon shows up too

~~~also after i post a poll, the thread is all f'd up, the format of the page is nothing like any of the others~~~
thats cause WritePollOrBallotHere shows up in the post, not the poll at all

help pleeze

[ June 02, 2001 03:49 AM: Message edited by: CtrlAltDel ]

Joined: Jun 2000
Posts: 150
Member
Member
Offline
Joined: Jun 2000
Posts: 150
well i couldnt figure it out, i got some more errors too, i musta done something really wrong, i'm restoring my backup, and i'll try again later today

time for sleep

Joined: May 2001
Posts: 52
Member
Member
Offline
Joined: May 2001
Posts: 52
CtrlAltDel --

I hope you didn't uninstall, because the fix is super easy.

Read LK's post, you just need to find in the lines that you added with {BBTopic} and replace BBTopic with BBPoll.

Anyway, the zip files are updated and Allen will be setting the link for the newest version to my beta site.

Download Now

Joined: Jul 2000
Posts: 81
Member
Member
Offline
Joined: Jul 2000
Posts: 81
Suggestion

add icons to icon legend table

someting like this :

*icon* New Votes on this poll! (*icon* Hot Poll More than XX vote)
*icon* No New Votes on this poll! (*icon* Hot Poll More than XX vote)

Joined: May 2001
Posts: 6
Junior Member
Junior Member
Offline
Joined: May 2001
Posts: 6
thx, superhack !

some little bugs, but no problem..... it works great ! wink laugh

Joined: Apr 2001
Posts: 26
Junior Member
Junior Member
Offline
Joined: Apr 2001
Posts: 26
I post a poll on my UBB and it comes up just as a normal thread without the poll stuff, and with the title saying [Poll] after it...

Joined: Apr 2001
Posts: 254
Member
Member
Offline
Joined: Apr 2001
Posts: 254
yeah same thing has happened here.

it also stopped my other poll hack working (u know the other allen one that its supposed to work with)
It keeps saying You dont have permission to do this when trying to edit Poll from CP.

anyway, on thishack, same problem as XuDuX

Joined: May 2001
Posts: 2,798
Member
Member
Offline
Joined: May 2001
Posts: 2,798
try rehacking it.. i hacked wrong first time and i did some wrong things try it again

Joined: Nov 2000
Posts: 48
Member
Member
Offline
Joined: Nov 2000
Posts: 48
I have the other poll added (the one where you add via the control panel).....Do I have to remove that one first ???


Burn
Joined: Dec 2000
Posts: 62
Member
Member
Offline
Joined: Dec 2000
Posts: 62
Quote
quote:
I got the same problem,i can't se the poll in the post + i got some software error when trying to reply to the poll post.
Sorry to say that i dident copy the error page before i uploaded the backups:(
Have tryed to insert the hack 2times now + i have looked at my code to be sure that there was nothing wrong.

Do i need to cmod the poll.pl file(can't remember the name) to something?
I tryed 644,775,777 with no luck also tryed to clear cache.

Joined: Apr 2001
Posts: 26
Junior Member
Junior Member
Offline
Joined: Apr 2001
Posts: 26
I've rehacked twice, its still doing the same thing, posting it like a normal thread without the poll itself

Joined: Apr 2001
Posts: 254
Member
Member
Offline
Joined: Apr 2001
Posts: 254
right, i just hacked it 3 times! still same problem as XuDuX
I solved my little other problem with the Previous Poll hack (uploaded wrong file DOH!)
But anyways, anyone got any ideas?
No polls are appearing at all!
its just a normal thread, if u put a comment in, the commet appears, no poll. add no comment it puts in the thread 'Voting With No Comment'
any ideas?

Joined: Apr 2001
Posts: 15
Junior Member
Junior Member
Offline
Joined: Apr 2001
Posts: 15
same thing happened to me when i tried to do it frown poll isn't showing up.

Joined: Jun 2000
Posts: 150
Member
Member
Offline
Joined: Jun 2000
Posts: 150
yep, doesnt work for me, and im running 6.04

guess i'll install the other poll hack sometime or something mad

Joined: Apr 2001
Posts: 3
Junior Member
Junior Member
Offline
Joined: Apr 2001
Posts: 3
Yeah I got this problem too No Polls are showing up only the comments. I ca reply to it with out any probs.

Btw I got another bug or something like that in the thread overview in each forum, I don't have a post poll button but two post new topic buttons. But The one to the right is actually the post poll button. In the thread the post poll button works is there.

Joined: Apr 2001
Posts: 254
Member
Member
Offline
Joined: Apr 2001
Posts: 254
Quote
quote:
ek! i have that prob too!
i hope these r easy problems to fix

Joined: Apr 2001
Posts: 3
Junior Member
Junior Member
Offline
Joined: Apr 2001
Posts: 3
Now I got the poll to work My Prob was in
ubb_lib_posting.cgi

I was too fast to copy paste hehe

$counter = 0;

I accidently put this part in after the comment in the line above.

But I still got To post New Topic Buttons, anyone have any Idea where I should fix this.

Found out about the button by actually reading all posts in this thread and clean my Cache.

[ June 02, 2001 05:26 PM: Message edited by: Santa ]

Joined: Apr 2001
Posts: 26
Junior Member
Junior Member
Offline
Joined: Apr 2001
Posts: 26
Hey Santa, that worked!!!!
Thanx

Joined: Apr 2001
Posts: 254
Member
Member
Offline
Joined: Apr 2001
Posts: 254
Santa! I LOVE YOU!!!!!!!!

Joined: Apr 2001
Posts: 254
Member
Member
Offline
Joined: Apr 2001
Posts: 254
right new problems!
when u vote, but make NO comment, it adds you to the thread and sez 'Voting With No Comment'.
Is that ok? it seems wrong. surely u can vote without it saying Voting With No Comment. or is that just a feature.
anyways, got the same prob as the rest of these kind people, 2 New Topic buttons!


*****EDIT******
SOLVED IT! FOR I AM GOD
damn VotingWithNoComment should have spaces in em!

[ June 02, 2001 07:50 PM: Message edited by: Cyberdude8472 ]

Joined: May 2001
Posts: 52
Member
Member
Offline
Joined: May 2001
Posts: 52
A buddy of mine found a bug, and you can test this by creating a poll with to identical options. YES||YES||No||Maybe

Well if you vote for YES, then both entries get incremented.

Ooops, Here is the fix.

Find:
Code
code:

Replace with:
Code
code:

I'll update the zip file.
Sorry about the mess I made on the page ...

[ June 02, 2001 09:45 PM: Message edited by: Olson ]

Page 1 of 6 1 2 3 4 5 6

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
badfrog
badfrog
somewhere on the coast of Maine
Posts: 94
Joined: March 2007
Forum Statistics
Forums63
Topics37,570
Posts293,918
Members13,848
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,830
Greg Hard 4,625
Top Posters(30 Days)
Gizmo 1
Top Likes Received
isaac 81
Gizmo 20
Brett 7
WebGuy 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2023 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Preview build 20221218)