Previous Thread
Next Thread
Print Thread
Rate Thread
Page 3 of 5 1 2 3 4 5
Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
er I just uploaded the compress folder with the file.

now:

Software error:
Can't locate MD5.pm in @INC (@INC contains: ./Modules . /usr/local/lib/perl5/5.6.0/i686-linux /usr/local/lib/perl5/5.6.0 /usr/local/lib/perl5/site_perl/5.6.0/i686-linux /usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl) at Modules/Compress/cgi_buffer.pm line 22.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:00:19 2001] ultimatebb.cgi: Can't locate MD5.pm in @INC (@INC contains: ./Modules . /usr/local/lib/perl5/5.6.0/i686-linux /usr/local/lib/perl5/5.6.0 /usr/local/lib/perl5/site_perl/5.6.0/i686-linux /usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl) at Modules/Compress/cgi_buffer.pm line 22. BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:00:19 2001] ultimatebb.cgi: [Sun Sep 30 21:00:19 2001] ultimatebb.cgi: Can't locate MD5.pm in @INC (@INC contains: ./Modules . /usr/local/lib/perl5/5.6.0/i686-linux /usr/local/lib/perl5/5.6.0 /usr/local/lib/perl5/site_perl/5.6.0/i686-linux /usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl) at Modules/Compress/cgi_buffer.pm line 22. [Sun Sep 30 21:00:19 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22. Compilation failed in require.

Sponsored Links
Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
ok I got the files in place I think in the compress folder, now it only gives me this error:

Software error:
package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:16:57 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. Compilation failed in require.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: Compilation failed in require. Compilation failed in require.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: Compilation failed in require. Compilation failed in require at Modules/MD5.pm line 22.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: Compilation failed in require at Modules/MD5.pm line 22. BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: Compilation failed in require at Modules/MD5.pm line 22. [Sun Sep 30 21:16:57 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22. Compilation failed in require.

Joined: Jun 2001
Posts: 94
H
Member
Offline
Member
H
Joined: Jun 2001
Posts: 94
heh
correct paths are:

/cgi-bin/Modules/Compress/cgi_buffer.pm
/cgi-bin/Modules/Digest
/cgi-bin/Modules/IO/String.pm

Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
you sure? cause I got this error when I did that:
Software error:
Can't locate MD5.pm in @INC (@INC contains: ./Modules . /usr/local/lib/perl5/5.6.0/i686-linux /usr/local/lib/perl5/5.6.0 /usr/local/lib/perl5/site_perl/5.6.0/i686-linux /usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl) at Modules/Compress/cgi_buffer.pm line 22.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:22:56 2001] ultimatebb.cgi: Can't locate MD5.pm in @INC (@INC contains: ./Modules . /usr/local/lib/perl5/5.6.0/i686-linux /usr/local/lib/perl5/5.6.0 /usr/local/lib/perl5/site_perl/5.6.0/i686-linux /usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl) at Modules/Compress/cgi_buffer.pm line 22. BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:22:56 2001] ultimatebb.cgi: [Sun Sep 30 21:22:56 2001] ultimatebb.cgi: Can't locate MD5.pm in @INC (@INC contains: ./Modules . /usr/local/lib/perl5/5.6.0/i686-linux /usr/local/lib/perl5/5.6.0 /usr/local/lib/perl5/site_perl/5.6.0/i686-linux /usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl) at Modules/Compress/cgi_buffer.pm line 22. [Sun Sep 30 21:22:56 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22. Compilation failed in require

Joined: Jun 2001
Posts: 94
H
Member
Offline
Member
H
Joined: Jun 2001
Posts: 94
edit cgi_buffer.pm
at line 22:

use MD5;

perhaps you should try this:

use Digest::MD5;

Sponsored Links
Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
yet it persists:
Software error:
package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:35:55 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. Compilation failed in require.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: Compilation failed in require. Compilation failed in require.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: Compilation failed in require. Compilation failed in require at Modules/Digest/MD5.pm line 22.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: Compilation failed in require at Modules/Digest/MD5.pm line 22. BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22.
For help, please send mail to the webmaster (Your Webmaster), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: Compilation failed in require. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: Compilation failed in require at Modules/Digest/MD5.pm line 22. [Sun Sep 30 21:35:55 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22. Compilation failed in require.


omg, I'm started to get tired of copy and pasting for the first time. no it didn't work, no changes in the error message I think.

Joined: Jun 2001
Posts: 94
H
Member
Offline
Member
H
Joined: Jun 2001
Posts: 94
dunno whats wrong confused
i've installed Allen's UBB compression hack and Phillip's UBB accelerator and both are working gr8 at my board smile
blistering fast laugh

Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
I needed php support for this hack right?

edit: what does this mean?
"use Compress::Zlib;" what's zlib?

[ 09-30-2001: Message edited by: Teleknesis ]

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
hmiguelito gave the correct paths... I guess I need to break down and write some better install docs wink

This one is beta, and I have no idea what .pm's you might already have installed, so it'd prolly be a good one to try on a test forum before putting up on your live site.

Try this one tele, make a directory in your Modules/Digest folder (Perl) and put a copy of the MD5.pm file in there so that it would lok something like this:

Modules/Digest/Perl/MD5.pm

That should give it the one it's looking for...


- Allen wavey
- What Drives You?
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
oops, forgot to answer the questions:

this one doesn't require php

zlib is the perl module used that actually does the compression.


- Allen wavey
- What Drives You?
Sponsored Links
Joined: Aug 2001
Posts: 68
S
Member
Offline
Member
S
Joined: Aug 2001
Posts: 68
yeah I think we should collect Questions and make a FAQ.

Joined: Aug 2001
Posts: 68
S
Member
Offline
Member
S
Joined: Aug 2001
Posts: 68
okay, set the right paths, but then I get something like a version dismatch I think:

Software error:
Digest::MD5 object version 2.13 does not match bootstrap parameter 2.16 at /usr/libdata/perl/5.00503/DynaLoader.pm line 188.

Software error:
Digest::MD5 object version 2.13 does not match bootstrap parameter 2.16 at Modules/Digest/Perl/MD5.pm line 16.


and below a lot of chunk data.

Joined: Mar 2001
Posts: 326
M
Member
Offline
Member
M
Joined: Mar 2001
Posts: 326
Well I've installed the cgi_buffer files and such to every possible DIR so that no matter where the system looks it should find what it needs.

Despite this I now get what 'Excellent' was seeing before he gave up, a very basic single line COMPILATION error for the ultimatebb.cgi file - no other details.

My settings are as follows:

Quote
quote:
Please note that I've also tried 'use cgi_buffer;' and that just caused an 'Internal Server Error'.

PerlDiver reports that all the needed stuff is installed, although nobody will answer my previous question about what IO::Stringy is? I don't have IO::String, just Stringy?

Is this the same? Should I update paths to reflect the 'y' on the end? What do I do.

Aside from that I'm stuck, all instructions followed and previous CHMOD's and dir structures obeyed. The fact it's just a basic compilation error means I'm one step away, but where now?

PS"6.04e"

Joined: Jun 2001
Posts: 94
H
Member
Offline
Member
H
Joined: Jun 2001
Posts: 94

Joined: Aug 2001
Posts: 68
S
Member
Offline
Member
S
Joined: Aug 2001
Posts: 68
I got rid of my problem by cheating a little bit laugh laugh laugh

if someone has same problem just have a look at this file: /cgi-bin/Modules/Digest/MD5.pm
and edit following code:
Code
code:
it is exactly line 6,

to $VERSION = '2.13';

For the experienced pplz: will the whole hack be useless by changing this ? or does it solve the error and all problems by changing...I dunno, I haven't notice any speed advantaged, so I want to know? Please answer !

Joined: Mar 2001
Posts: 326
M
Member
Offline
Member
M
Joined: Mar 2001
Posts: 326
Well CPAN search explained String vs Stringy, not that it helps since I'm past the 'software' error part and the modules must be loading, it's just UBB6.04e refuses to compile (see above error).

Any help? Anybody come accross this and get it solved?

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
MD5 is a perl module for encryption, I am not sure if changing the version # will make any difference in performance in this. The best way to check (providing you aren't getting any errors now) is to load your site and see what size a good-sized downloaded page is (in IE, right-click on a thread's page and select "properties", it should be a very small 5-12kb or so file).

Mark smile Try moving the first 3 line below the use strict; I am grasping at straws here since I can't actually see what's going on. smile Do you also have String.pm in a Modules/IO (case sensitive) directory?

Be sure you have set permissions on the directories and .pm's so they can be read as well smile

[ 10-01-2001: Message edited by: AllenAyres ]


- Allen wavey
- What Drives You?
Joined: Aug 2001
Posts: 68
S
Member
Offline
Member
S
Joined: Aug 2001
Posts: 68
Yes I think it works. But in comparing to the original one there are 100 bytes less, not more, it's not very much isnt it ?
Without Hack: 7172 bytes
With Hack: 7074 bytes


= 98 bytes less

I do not think it's worth to install the hack, right ?

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
That's odd.. it's usually more like 80-120kb before, 5-12kb after... is most all pages like that?


- Allen wavey
- What Drives You?
Joined: Sep 2000
Posts: 67
J
Member
Offline
Member
J
Joined: Sep 2000
Posts: 67
Quote
:
Heading there to try it Allen- I am getting the same errors that omegatron and others are with the 'vars not registered for warnings' then the failure of autoloader.pm, etc...
Going to redownload now and see what happens...

Joined: Sep 2000
Posts: 67
J
Member
Offline
Member
J
Joined: Sep 2000
Posts: 67
Still getting the same errors on my end...



Software error:
package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Tue Oct 2 00:01:35 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4.
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. Compilation failed in require.
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. Compilation failed in require.
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. Compilation failed in require.
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. Compilation failed in require at /usr/local/share/perl/5.6.0/MD5.pm line 22.
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require at /usr/local/share/perl/5.6.0/MD5.pm line 22. BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22.
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error. Content-type: text/html

Software error:
[Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: package 'vars' not registered for warnings at Modules/AutoLoader.pm line 4 [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/AutoLoader.pm line 4. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: Compilation failed in require at /usr/local/share/perl/5.6.0/MD5.pm line 22. [Tue Oct 2 00:01:35 2001] ultimatebb.cgi: BEGIN failed--compilation aborted at Modules/Compress/cgi_buffer.pm line 22. Compilation failed in require.
For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error.

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Which version UBB are you running? It may be that your version isn't running cleanly under "use strict;"


- Allen wavey
- What Drives You?
Joined: Aug 2001
Posts: 68
S
Member
Offline
Member
S
Joined: Aug 2001
Posts: 68
These values are taken from your suggested method: IE - File - Properties, I compared the displayed values, those one I mentioned above.
I think you mean that mathod or did I compared the wrong values?

Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
is it maybe because I upgraded from ubb 6.05? btw I'm doing this on a test board. I getting the same errors as the others, vars not registered for warnings. frown

Joined: Jun 2001
Posts: 94
H
Member
Offline
Member
H
Joined: Jun 2001
Posts: 94
wow Allen
damn thing works with 5.x UBB versions eek

Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
disregard my previous question, I just tried it on another 1.4 board that was freashly installed and not upgraded, and it got the same error. Can some one give me the EXACT directions for the thing? the one in the front is a bit confusing..

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
hmiguelito laugh I think you are irritating the others who haven't got it working on one version yet laugh

tele, upload the files in the zip into their respective folders in the Modules directory.

Modules/Compress
Modules/IO
Modules/Digest
Modules/Digest/Perl

In ultimatebb.cgi uncomment "use strict;" and "use vars" and add these lines to it so that it looks like this:

require Modules::Compress::cgi_buffer;
import Compress::cgi_buffer
$cgi_buffer::generate_etag = 0;
use strict;
use Fcntl ':flock';
use UBBCGI qw(:cgi);
use UBBCGI::Carp qw(fatalsToBrowser set_message);

use vars

If it doesn't work after this, it is possible you still don't have all the modules installed, or you have them in binary, or you have permissions set to where they can't be read.


- Allen wavey
- What Drives You?
Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
alright, do you mean I have to have a seperate "digest" folder for "perl"? I'm sorry if I'm frustrating to you. smile

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
smile

Add a "Perl" directory to your "Digest" Directory... the pm's are looking for MD5 in both the Digest and the Perl folders.


- Allen wavey
- What Drives You?
Joined: Jun 2001
Posts: 94
H
Member
Offline
Member
H
Joined: Jun 2001
Posts: 94
Quote
quote:
oops sorry laugh

this is what it looks like at my server:

/cgi-bin/Modules/Compress/cgi_buffer.pm

/cgi-bin/Modules/Digest/HMAC.pm
/cgi-bin/Modules/Digest/HMAC_MD5.pm
/cgi-bin/Modules/Digest/HMAC_SHA1.pm
/cgi-bin/Modules/Digest/MD2.pm
/cgi-bin/Modules/Digest/MD5.pm
/cgi-bin/Modules/Digest/SHA1.pm.

/cgi-bin/Modules/Digest/Perl/MD5.pm

/cgi-bin/Modules/IO/String.pm

/cgi-bin/Modules/MIME/Lite.pm

/cgi-bin/Modules/Net/Cmd.pm
/cgi-bin/Modules/Net/Config.pm
/cgi-bin/Modules/SMTP.pm

/cgi-bin/Modules/UBBCGI/Carp.pm
/cgi-bin/Modules/UBBCGI/Cookie.pm

[ 10-01-2001: Message edited by: hmiguelito ]

Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
Allen, um when I went to ultimatebb.cgi for the first time before I even touched the web browser to view it, the use srtict was already uncommented, is it suppose to be like that?


edit: they still don't work..

[ 10-01-2001: Message edited by: Teleknesis ]

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
they are uncommented in the newer beta's... I had that in there for those running on the little older 6.0x series...

This is simple to install and it's possible that your server either doesn't have the proper modules installed, or that maybe there's some type of compression already running and messing this one up.

To test that, go to this page: http://leknor.com/code/gziped.php - input a url to a file on your site and see what the results are. smile


- Allen wavey
- What Drives You?
Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
um I don't know about you, but I'm on dial-up and that url is taking forever. um while I'm waiting, what does it do?

Joined: Sep 2000
Posts: 67
J
Member
Offline
Member
J
Joined: Sep 2000
Posts: 67
I've noted no issues with strict to date-- I can't see the server having any problems with it as it has had no past issues to my knowledge...

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
OP Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
If your install is correct and you are still having problems, then it would have to mean that the correct perl modules are not compiled on your server. It works for hmiguelito on all his sites because the pm's are installed, for others the same.

Run perl diver, if you are missing one of the perl modules, please ask your web host providor to install those missing. It's a simple process and doesn't degrade performance.


- Allen wavey
- What Drives You?
Joined: Mar 2001
Posts: 326
M
Member
Offline
Member
M
Joined: Mar 2001
Posts: 326
Allen:

Quote
quote:
You need to work on those instructions =), where would I move them to?

Sadly I just don't think this is going to work and yes string.pm is copied multiple times in every single possible DIR (yes used ASCII and 755) mentioned through these threads - no go.

My PerlDiver is here:
http://www.ispreview.co.uk/cgi-bin/perldiver.cgi

IO:String is all I miss from the server itself, but the compilation error I get suggests that its moved past calling the scripts and just can't compile it all into an active state.

Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
what modules would those be? I'll ask the server person to install it, or I'll use my other server hoster person. tipsy

Joined: Jun 2001
Posts: 297
T
Member
Offline
Member
T
Joined: Jun 2001
Posts: 297
I installed it on the NT server my other test board was on, and it's ok. I dunno if it worked or not because it seemed normal but I haven't used that test board a for awhile, except for the upgrade and I don't know about the speed variation..

edit: sorry it was suppose to be "NT" instead of NET

[ 10-02-2001: Message edited by: Teleknesis ]

Joined: Mar 2001
Posts: 326
M
Member
Offline
Member
M
Joined: Mar 2001
Posts: 326
For the record I don't think this likes one of the hacks in v6.04e. No idea which.

Quote
quote:
I say this because I just installed a v6.1B2 test board and used EXACTLY the same settings and it worked, but not on v6.04e (has lots of hacks installed).

I also tried using the new 6.1B2 call modules command at the top of ultimatebb.cgi and it still gave the same error. Clearly one of the hacks is causing problems, either that or it just won't work with v6.04e.

Joined: Mar 2001
Posts: 326
M
Member
Offline
Member
M
Joined: Mar 2001
Posts: 326
Hold on a second, when you do get it working, how do you know it's saving any bandwidth?

The before and after 'SOURCE' (Using IE - View Source command and save the file) files, even on forums supposedly using it with sucess (https://www.ubbdev.com/test/ubbcgi/ultimatebb.cgi) are identical to those without it.

I heard somebody say that the system works by compressing a file when it's called and then uncompressing it on the persons system (once it's streamed I assume?).

Thus how do you know whether you've saved any bandwidth or not, people keep saying thinks like, "My 15K file went to 8K", etc., but how do you know? How do you test? Where's the physical proof this actually works? Help =).

Page 3 of 5 1 2 3 4 5

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Posts: 70
Joined: January 2007
Forum Statistics
Forums63
Topics37,569
Posts293,914
Members13,847
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,829
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 81
Gizmo 20
Brett 7
Morgan 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2022 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Snapshot build 20220917)