Previous Thread
Next Thread
Print Thread
Rate Thread
Page 2 of 3 1 2 3
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
up to 4.1 I see wink

I have an mhp ready when this goes final smile


- Allen wavey
- What Drives You?
Sponsored Links
Joined: Mar 2002
Posts: 451
O
Spotlight Runner-Up
Offline
Spotlight Runner-Up
O
Joined: Mar 2002
Posts: 451
Quote
quote:
Originally posted by Oblivion Knight:
Would it be possible to add a link to the smilie legend that "DPK's SmilieMod" installs below "HTML is not enabled." and "UBB Code is enabled."? If so could anyone explain to me how to go about doing this..? I tried and got an error with ubb_lib_posting.cgi when i'd edited public_topic_page.pl, so I won't be trying it again, I'll leave it to the professionals.. smile
.

Bump smile

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
I don't know that one yet OK...

Multihack file with latest changes posted here:

https://www.ubbdev.com/db/cgi/ultimatebb.cgi?ubb=get_topic&f=22&t=000050


- Allen wavey
- What Drives You?
Joined: Jan 2002
Posts: 34
J
Junior Member
Offline
Junior Member
J
Joined: Jan 2002
Posts: 34
Thanks, going to try this one!

Joined: Jul 2002
Posts: 9
A
Junior Member
Offline
Junior Member
A
Joined: Jul 2002
Posts: 9
sheesh Allen,

I wish I had known you were going to do a multi-hack file. I had created my own, what a frigging pain!!!!!!

Thank you for making one, as yours, no doubt will be correctly documente, whereas mine is not. smile

This will make installing this hack a breeze.

Sponsored Links
Joined: Feb 2000
Posts: 4,625
G
Member
OP Offline
Member
G
Joined: Feb 2000
Posts: 4,625
Thanks AA. smile

Joined: May 2001
Posts: 180
D
Member
Offline
Member
D
Joined: May 2001
Posts: 180
There is a small bug in it :

When you have a forum where just admins and mods are allowed to post, the preview function is not working correctly when you reply and you are just a normal member.

Try here yourself if you want :

http://www.forumdeluxx.com/ubb/ultimatebb.php?ubb=forum;f=8


Regards Dennis Bode
-----------------------------
Webmaster of Hardwareluxx.com
Joined: Aug 2002
Posts: 97
C
Member
Offline
Member
C
Joined: Aug 2002
Posts: 97
Please fix the link smile

http://www.coders-net.com/beta/quickreply.txt seems to be dead

Joined: Mar 2001
Posts: 7,394
L
LK Offline
Admin / Code Breaker
Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394

Joined: Dec 2000
Posts: 151
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 151
Alright!

Just installed the MOD on my test board.

For its main purpose (QuickReply DOH!) it works perfectly so far.

Having read things about the registration I decided to test that.

When registering everything was fine -
There was a radio box option to turn on or turn off the QuickReply feature -

However, after registering, when it shows the recap of what I have selected and filled out -

Under "Your Preferences"

There is no mention of the QuickReply feature

Not sure if I have put code in wrong, this was intentionally left out, or simply an oversight, but it should be there since it was a preference that we had the ability to select upon registration.

Hmmm, just did some more testing in the profile area -

When viewing the profile it shows the option to "Show QuickReply Box?"

However it defaults to "Yes" even after having checked "No".

(NOTE: when checking no it does in fact not show the box - so it is set and working correctly it is just that when viewing the profile that it defaults to yes when it should be showing no if that is what had been selected.)

Both of the things I have noticed are very minor in relation to the usability of the MOD but should be "fixed" (I quote "fixed" because I am not sure I made errors installing the code from the text file or if these are actual "bugs" in the code.)

Great MOD though! And really great that users are given the option to have the quickreply feature turned off or on.

Sponsored Links
Joined: Dec 2000
Posts: 151
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 151
Ok, now I am convinced I have erred in at least one area of the install.

I noticed here on UBBDev that if "No" is selected it stays selected when coming back into the "MyProfile" and on my test board I turned the feature off (for one of my test registrations) and now cannot get it to come back on.

Going to try to find what I did wrong frown

Joined: Dec 2000
Posts: 151
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 151
Hmmm... a little more information for you

I decided to log off of one name and log on the other.

On a registered name (on test board) that was registered before this MOD was installed I can turn on and turn off the QuickReply Box with no problems.

On the name I registered after installing the MOD, if I turn it off and then turn it back on, the QuickReply box does not show up. However, if I log that name off and then log back on, it will be there.

I cannot remember if when I registered that name if I selected yes or no - so I'm going to go try both ways with two new registration names and see what happens.

I'll report the results soon!

Joined: Dec 2000
Posts: 151
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 151
Alright I have done much testing....

I think it would be easier for you (whoever wants to see what I have done) to go to my test board and follow along (Forum #2 - thread is obvious) my posts to see the steps I took.

New "bug" (or bad install by me) detected:
When registering - I selected "No" and yet the box still showed.

my test board is:

http://iambornagainru.org/cgi-bin/babtest/ultimatebb.cgi

I only have one other MOD installed (Stats)

Joined: Sep 2002
Posts: 1
M
Junior Member
Offline
Junior Member
M
Joined: Sep 2002
Posts: 1
Hmmmm....

(Note this is CaCoffin - registered with a new name here to see if the same problems exist here - so I can tell where the problem is - me or the code)

Most of the errors I have mentioned must be with my install since only one error I mentioned occurs here. (Unless whoever did the install here fixed those errors on their install wink )

The only error (two actually) that happen here are:

1) Upon registration I selected NO but the QuickReply Box still appeared.

2) Upon registration the Preferences review does not show the QuickReply option

Otherwise everything else works as it should here.

Sooooo now I have to figure out what I did wrong on the install (at least I know to look in the profile files).

Joined: Dec 2000
Posts: 151
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 151
LOL

and a YeeeHaaawww

I found MY error!

I managed to drop off the semi-colon when adding the line for storing myprofile:

Code
$user_profile[61] = $quickreply;
I managed to not copy the semi-colon the first time around - added that and ALL the problems (but those two above) are gone.

The two problems I mentioned above as MrTester are here and on my test board so they are definitely errors in the MOD.

But without saying, this MOD rocks (when installed properly wink ), and thank you!

Oh by the way - ADMIN for UBBDev please feel free to delete MrTester, thank you.

Oh and if they do the two errors that are real errors are:

1) Upon registration when "No" is selected the QuickReply option is turned on anyways.

2) Upon registration the Preferences review does not show the QuickReply option.

Joined: Mar 2001
Posts: 7,394
L
LK Offline
Admin / Code Breaker
Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
open public_register_form.pl.
find:
Quote
code:
Code
print &GenerateLineHTML("REQ", "Show Quick Reply Box?", "", "quickreply", "radio", { yes => $vars_wordlets{yes_option}, no => $vars_wordlets{no_option} }, [qw(yes no)], "yes");

replace with:
code:
[qb]
Code
print &GenerateLineHTML("REQ", "Show Quick Reply Box?", "", "quickreply", "radio", { 1 => $vars_wordlets{yes_option}, 0 => $vars_wordlets{no_option} }, [qw(1 0)], 1);
[/qb]
It's untested, but hmm, should work.. tipsy

Joined: Dec 2000
Posts: 151
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 151
Consider it tested and working....

Now how about showing the option as selected upon registration review?

Joined: Dec 2000
Posts: 151
C
Member
Offline
Member
C
Joined: Dec 2000
Posts: 151
Though it might be obvious for most of you perhaps adding the words "CLEAR YOUR CACHE" at the end of the instructions might save a few of us knucklheads some time (and banging our heads on tables).

LOL

Great MOD - works great from the go - easy enough to install too ....

Joined: Jan 2002
Posts: 34
J
Junior Member
Offline
Junior Member
J
Joined: Jan 2002
Posts: 34
C'mon, make a multihack file smile I'm lazy wink

Joined: Mar 2001
Posts: 7,394
L
LK Offline
Admin / Code Breaker
Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
Sorry to disappoint you, but Allen has already made a MHK file wink
Quote
quote:
Originally posted by AllenAyres:
I don't know that one yet OK...

Multihack file with latest changes posted here:

https://www.ubbdev.com/db/cgi/ultimatebb.cgi?ubb=get_topic&f=22&t=000050

Joined: Jan 2002
Posts: 34
J
Junior Member
Offline
Junior Member
J
Joined: Jan 2002
Posts: 34
Quote
quote:
Originally posted by LK:
Sorry to disappoint you, but Allen has already made a MHK file wink
quote:
[qb]Originally posted by AllenAyres:
I don't know that one yet OK...

Multihack file with latest changes posted here:

https://www.ubbdev.com/db/cgi/ultimatebb.cgi?ubb=get_topic&f=22&t=000050
[/qb]

Woops, srry tipsy Tnx anyway!

Joined: Sep 2002
Posts: 26
F
Junior Member
Offline
Junior Member
F
Joined: Sep 2002
Posts: 26
How do I add Spell Check to the Quick Reply Box?

Joined: Feb 2001
Posts: 125
D
Member
Offline
Member
D
Joined: Feb 2001
Posts: 125
can anyone send me quick reply for ubb 6.2.1 please? or tell me where to download from
The link from the 6.2 forum doesn't work

Joined: Sep 2002
Posts: 26
F
Junior Member
Offline
Junior Member
F
Joined: Sep 2002
Posts: 26
OK... I'll ask again.

How can we add Spell Check for Quck Reply? Please help.

Joined: Mar 2001
Posts: 7,394
L
LK Offline
Admin / Code Breaker
Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
I think I said it many times in the previous threads. What I do is use:
Code
	my $spellcheck_button = (
$vars_modifications{spellcheck_enable} ne "no"
? qq( <input type="button" name="spellcheck" value="$vars_wordlets_mods{spell_check}" onclick="window.open(\'$vars_config{CGIURL}/ubb_spell.cgi?f=$in{f};ubb=www.spellcheck.net%2Fcgi-bin%2Fspell.exe%3Faction%3Dcheckpg%26string%3D\'+escape(document.replier.message.value), \'message\', \'toolbar=yes,menubar=no,location=no,resizable=yes,scrollbars=no,status=no,width=$vars_modifications{spellcheck_width},height=$vars_modifications{spellcheck_height}\');" />)
: ""
);
Right after my $preview_button = ( .... )

Then add $spellcheck_button right after $preview_button in the document.write line.

Joined: Oct 2001
Posts: 28
R
Junior Member
Offline
Junior Member
R
Joined: Oct 2001
Posts: 28
It´s necessary to make Ultimatebb.cgi modified??? I got error doing that on 6.3.1.1 and I replaced with the other and everything is nice!

Joined: Oct 2001
Posts: 28
R
Junior Member
Offline
Junior Member
R
Joined: Oct 2001
Posts: 28
Got this error on clicking in "My profile"
[QUOTE]
CGIPath/ubb_profile.cgi: syntax error at CGIPath/ubb_profile.cgi line 955, near ")
||"
syntax error at CGIPath/ubb_profile.cgi line 977, near "} else"

Please inform the board administration of this error so that they may fix the problem. Thank you! [QUOTE]

Joined: Mar 2001
Posts: 7,394
L
LK Offline
Admin / Code Breaker
Offline
Admin / Code Breaker
L
Joined: Mar 2001
Posts: 7,394
Can you post ubb_profile.cgi line 950 - 985?

Joined: Oct 2001
Posts: 28
R
Junior Member
Offline
Junior Member
R
Joined: Oct 2001
Posts: 28
I´ve got the error and correct sorry for troubles

And sorry for my english

Joined: Sep 2002
Posts: 26
F
Junior Member
Offline
Junior Member
F
Joined: Sep 2002
Posts: 26
LK,

I should've done a search prior to asking. I found the original thread. Thank you again. You've been very helpful as always.

forever grateful,

-j

Joined: Jan 2000
Posts: 5,819
Likes: 16
UBBDev / UBBWiki Owner
Time Lord
Offline
UBBDev / UBBWiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,819
Likes: 16
can anyone email this to [email protected] the link doesn't work lol..


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, My UBB Scripts
Joined: Oct 2000
Posts: 40
D
Member
Offline
Member
D
Joined: Oct 2000
Posts: 40
Can some one format the code to work with Blam Templates. When this is installed it blows the tables. Let's face it the template ROCKS! But if I can't have the template there will be many that will have to choose one or the other and thats such a waist..


Newbie From Hell
Joined: Jan 2002
Posts: 27
M
Junior Member
Offline
Junior Member
M
Joined: Jan 2002
Posts: 27
Site with code is down...=( Can anyone post a link to it that works............ I just updated my forum...and members arent happy that quick reply isnt there any more...and i dont have the old version still so i can add it....

if you could send via AOL IM, would be good too...either is appreciated... IM name = tabigtoad

or email me at [email protected]

Thanks

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3


- Allen wavey
- What Drives You?
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Quote
quote:
Originally posted by DOD-THE KAHN:
Can some one format the code to work with Blam Templates. When this is installed it blows the tables. Let's face it the template ROCKS! But if I can't have the template there will be many that will have to choose one or the other and thats such a waist..
I'll look at it, should be simple smile


- Allen wavey
- What Drives You?
Joined: Jan 2002
Posts: 27
M
Junior Member
Offline
Junior Member
M
Joined: Jan 2002
Posts: 27
Thanks Allen...much appreciated =)

Joined: Mar 2001
Posts: 65
K
Member
Offline
Member
K
Joined: Mar 2001
Posts: 65
Before I may go into it, has somebody merged the quickreply with the email-on-reply hack?

Joined: Mar 2001
Posts: 65
K
Member
Offline
Member
K
Joined: Mar 2001
Posts: 65
Maybe somebody else could test this as well. All I did to get quickreply with Emailonreply (4.0) to work was:

public_topic_page.pl:

Look for:
Quote
code:
Code
sub topic_bottom {

@this_forum = &GetForumRecord($in{f});

my ($is_html, $is_ubb) = (&CheckCoding($this_forum[4], $this_forum[5], $this_forum[10]))[3,2];

Add below:
code:
[qb]
Code
my ($email_notify, $email_checked);
if (($vars_email{UseEmail} eq 'ON') && ($username ne '')) {
if (($stat_line[1] =~ /$user_number/) &#0124;&#0124; (($stat_line[1] =~ /N/i) && ($in{reply_num} eq '000000'))) {
$email_checked = 'CHECKED';
} else {
$email_checked = '';
}
$email_notify = qq(<INPUT TYPE="CHECKBOX" NAME="email_notification" VALUE="yes" $email_checked> $vars_wordlets{email_notify}
);
}
[/qb]
Look for:
Quote
code:
Code
if('0'!=user_array[10]) {
document.write('<form name="replier" method="post" action="$vars_config{CGIURL}/ultimatebb.cgi">

and put
code:
[qb]
Code
$email_notify
[/qb]
where you would like it to be displayed.

Seems to work for me...

Joined: Sep 2002
Posts: 35
J
Member
Offline
Member
J
Joined: Sep 2002
Posts: 35
anyone have this hack, the download is not working??

NEVERMIND about the link i got it @ https://www.ubbdev.com/hacks/6.3/quickreply.txt

KWIK, did that work for you.. the email reply hack, cuz i want that to be there too!! and what about adding signatures too???

Joined: Mar 2001
Posts: 65
K
Member
Offline
Member
K
Joined: Mar 2001
Posts: 65
It seems, that it does not work correctly. Some threads save the data wrong. Sometimes (not allways) there is a "," missing when saving the member-numbers which should be informed on a reply.

Page 2 of 3 1 2 3

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Bill B
Bill B
Issaquah, WA
Posts: 87
Joined: December 2001
Forum Statistics
Forums63
Topics37,558
Posts293,857
Members13,848
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online
Topics Created
Posts Made
Users Online
Birthdays
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,819
Greg Hard 4,625
Top Posters(30 Days)
Top Likes Received
isaac 70
Gizmo 16
Brett 7
WebGuy 2
Top Likes Received (30 Days)
None yet
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2022 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 8.0.0
(Snapshot build 20220120)
Responsive Width:

PHP: 7.3.29 Page Time: 0.060s Queries: 95 (0.033s) Memory: 1.0029 MB (Peak: 1.2039 MB) Data Comp: Zlib Server Time: 2022-01-27 06:09:07 UTC
Valid HTML 5 and Valid CSS